Support » Fixing WordPress » Import Feature Does Not Import File Attachments

  • I have a WP XML export file I’m importing (3.03 to 3.03). The import goes fine, but when I check the option to “Download and import file attachments” it does nothing. No attachments are imported. No file paths change in the post and no files show up in the uploads directory.

    I tried again after CH modding the folder to 777, just in case it was permissions, but no change. It’s like WP totally ignores all attachments even though you check the box.

    Any thoughts? Would really like this to work so I can being in image to new location and not have new site depend on files that exist on old site.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Dion Hulse


    Core Developer

    Are the images still accessable at their previous locations? WordPress Export files do not include the attachments in the backup file, just the posts, The Importer attempts to download them from the original server.

    Another option could be that your new installation cannot make outgoing Web requests, Can you browse plugins through the plugin installer? (That will show if it can make outgoing requests)

    Yes, they are still at the location. The images are fully available to be download. Also yes, the plugin installer works just fine. The feature just doesn’t work at all it seems.

    same here. importing wont download and upload attachments. any luck? really need this feature.

    I’m also having this issue.

    Does the WP XML need to have any special fields to let the new install know there are attachments to download?


    same problem here.

    still not working. both blogs are 3.0.4. i also tried setting wp-content/uploads to 777. i also tried manually adding the subfolders for the media (e.g. 2007/12). but still media is not attached even when i check the download and import attachments. no such luck. 🙁

    Hi all. I [sorta] figured out my problem here.

    If I only export a selection of posts using the provided drop downs (lets say selecting to export only from a particular category) and then IMPORT, I DO NOT get any file attachments to transfer according to my checkbox preference. I do not receive any errors, and all selected post data gets imported.

    However, if I select to just export ALL posts from a blog, ignoring the dropdown options provided, and then IMPORT from that file, I DO INDEED get all attachments and post data uploaded and transfered to the new blog.

    gee that’s not good. i have a huge blog and i can’t transfer them all in one go due to limitations so i’m doing it per category per year.

    I had the same situation… and wanted to do them individually…

    but i trusted the importer (as i’ve used it before) and I imported exactly 2600 posts at once… took a while… i don’t remember how long…. but at least 30+ minute i believe… but the importer is pretty awesome… batching it all out. worked just fine.

    give it a try. you may be surprised…..

    Just updated to 3.04 and the importer is still broken. I don’t get why this is always such a fiasco. Why have a feature if it does not work for most users.

    monggushu. Using the import all approach may be a workaround, but it’s not a great one because it means we can’t choose what we import. I did try it. It worked the first time, importing images along with content. But the posts were still in the trash from the previous import and because of that it did not update the posts to reflect the new image locations. I deleted everything and tried again using the same settings and it did not import images this time.

    This is a pretty basic feature. I’m really getting frustrated that WP can’t handle it.

    I did find another workaround. Certainly no fox, but it got me running.

    I downloaded the export file. Then opened in a text editor and did a find and replace on the image path that leads to the uploads dir (replacing old domain with new).

    Then I download all the image directories from the old domain and re-uploaded into the uploads folder of the new.

    Importing the modified xml file into the new domain and leaving import images NOT checked, the posts imported with the new modified image paths that lead to the image folder I uploaded.

    The posts are displaying fine, but this is still not a great solution. If you had content to import from more than one site it would be an even bigger pain. Please get this fixed WP team. The importer is important.

    I’m having the same problem when doing a selective export of posts by username. Although “download and import file attachments” is checked, no images are uploaded to the target server. I have upgraded both WP instances to WP v3.2.1 and the WordPress Import plugin to v0.5.

    same here..
    not a single attachment imported.



    I’ve noticed the problem, but I’ve only attempted it with a custom post type. Unfortunately, it’s going to be a major problem to fix manually.



    Probably get attacked for being strictly off topic here but it strikes me that as I understand it, the wp importer is generally too restrictive when it comes to images/ files.

    Given that this is usually being done by people who are not entirely technophobic then would it be so daft to have a few options on the importer?

    For example, how about an option to just update the domain part of a URL to a new one (implicitly “because I’ll ftp the actual images to the right place myself”).

    In my case I want that as I have a local machine for dev and for various reasons our live server just won’t upload the images from there. I don’t care to solve those reasons why.

    FWIW I use the “ventrilqstman” method (see above)

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Import Feature Does Not Import File Attachments’ is closed to new replies.