Support » Plugin: WooCommerce Admin » Import fails, create table error

  • Resolved Hans Schuijff

    (@hanswitteprins)


    I’ve installed woocommerce admin on three websites. Two of which run fine. The import of users and orders worked and the stats are presented like supposed. One had only about 20 orders in it and the second about 550.

    The third website doesn’t build and show stats. This website has close to 1600 orders of which some subscriptions and renewals.

    The plugin seems to install fine and when I try to import previous users and orders it seems to count up and seems to run fine until finalizing, but then endlessly remains in that state.

    Looking at the php log I find it reported some errors. The first and most important seems to be an error creating the stats table.

    [25-Sep-2019 17:47:33 UTC] WordPress database error Index column size too large. The maximum column size is 767 bytes. in query

    
    		CREATE TABLE prefix_wc_order_stats (
    			order_id bigint(20) unsigned NOT NULL,
    			parent_id bigint(20) unsigned DEFAULT 0 NOT NULL,
    			date_created datetime DEFAULT '0000-00-00 00:00:00' NOT NULL,
    			date_created_gmt datetime DEFAULT '0000-00-00 00:00:00' NOT NULL,
    			num_items_sold int(11) DEFAULT 0 NOT NULL,
    			gross_total double DEFAULT 0 NOT NULL,
    			tax_total double DEFAULT 0 NOT NULL,
    			shipping_total double DEFAULT 0 NOT NULL,
    			net_total double DEFAULT 0 NOT NULL,
    			returning_customer boolean DEFAULT NULL,
    			status varchar(200) NOT NULL,
    			customer_id BIGINT UNSIGNED NOT NULL,
    			PRIMARY KEY (order_id),
    			KEY date_created (date_created),
    			KEY customer_id (customer_id),
    			KEY status (status)
    		) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci gemaakt door activate_plugin, do_action('activate_woocommerce-admin/woocommerce-admin.php'), WP_Hook->do_action, WP_Hook->apply_filters, Automattic\WooCommerce\Admin\FeaturePlugin->on_activation, Automattic\WooCommerce\Admin\Install::create_tables, dbDelta
    

    Is it a bug, or do you have problem solving suggestions? Until now I haven’t been able to use the plugin successfully.

    I run the latest versions of wordpress and all plugins. Server is nginx/1.15.12 Php version 7.2.17, MySQL-versie: 5.5.5-10.1.38-MariaDB, cURL Versie: 7.29.0, NSS/3.36

    Hans

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Import fails, create table error’ is closed to new replies.