Support » Fixing WordPress » Import doesn't seem to be finishing – I think

  • Hi. I’m trying to import my export file.

    There are a bunch of messages like:

    Media “Hao falls asleep on my hand” already exists.

    which makes sense since I deleted all the old posts but didn’t delete the media.

    Yet… it seems to have stopped at that last message and isn’t continuing. I think it’s not doing anything anymore The URL is stopped at


    It’s not adding any more lines, or telling me it’s done or still processing or anything like that.

    If I visit in another tab there are 0 posts.

    What should happen?



Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    It looks like you have issues on your site that is causing severe problems for the importer. I suggest that you remove all replicated/unwanted media from your .com site and set your permalinks to the default setting. Then create a new export file and try the import again.

    It’s just all… weird.

    I deleted that WordPress instance and recreated a new one and ran the importer again. I still got those messages, but it stopped at a different point.

    There are no posts, but now there are 272 media files. Here at there are 1,155 media files.

    I think the importer just doesn’t work.

    Meanwhile here at I ran the importer back in March to import from Posterous. But looking today I realize that lots of old messages with YouTube links in them simply did not import the YouTube links at all.

    So what I’m left with is that the only 100% working site is my Posterous blog. But I would like to get away from them because the handwriting is on the wall there.

    But where to go?

    Here there are problems with email notifications and the Invite system is buggy.

    With a self-hosted WordPress blog the content doesn’t import.

    And even if it did, the content on my blog here didn’t 100% import from Posterous.





    Forum Moderator

    I think the importer just doesn’t work.

    It does work. I used it about 14 hours ago to move content from a dev site to a production site and it worked flawlessly. All in all, I’ve used it countless times – without any problems.

    When there have been problems, these have always been traced back to issues within the exported content – either due to a plugin inserting content into the database in a non-standard manner or because something in the import was so large that it just plain timed out.

    In this case the exporter is the exporter here at I don’t really have control over what it is exporting.

    It might be timing out. It seems to be. The import file is just 4.8 MB in size though.

    I’m re-running it and this time it seems to be getting farther. Maybe there is a timeout with and I just have to keep on re-running it over and over again until it gets everything?


    It seems that every time I run it it races through the messages like:

    Media “Today’s quake activity – 5 of them between 4.4 and 5.9” already exists.

    and then goes on and gets some more. So I do think it is just timing out with

    I’ll keep running it over and over again until it thinks it’s finished and see what happens.





    Forum Moderator

    In this case the exporter is the exporter here at

    This is – not .com. There is a difference 🙂

    The import file is just 4.8 MB in size though.

    That’s a pretty big export file! Perhaps you need to split it down. Have a look at

    I just have to keep on re-running it over and over again until it gets everything?

    No – that’s one sure way to end up with lots of replicated content.

    Oops-a-doodle. I got mixed up at which site I was at. Sorry about that.

    Well, I did run it 5 times and it did seems to finish correctly then with the “have fun” link.

    And perusing through the blog ( there doesn’t seem to be replicated content.

    I think what was happening was that it was repeatedly getting timed out. But the importer is aware of duplicated (thus all those “already exists” messages) and avoids replicates.

    Each time it got more and more because it was able to quickly skip over what it already imported.

    So eventually it finished.

    The only immediate issue I see is that YouTube embeds all look like:


    I suppose there is some setting to expand it somewhere. I’ll hunt around.

    Thanks for your assistance, esmi.


    Just to confirm, at both and the imported there are exactly 708 posts going back to 2007.

    So there were no replicates.

    I just needed to run the importer over and over again each time it timed out until it finally finished.


    Esmi, this is working great. The learning curve is very low, and there seems to be a plugin for just about everything I can imagine. Don’t like the default tags cloud? Switch it out for another widget. Want to expand embeds? Add a widget. Fun!

    I’m off to look for ways to easily import my subscribers from Posterous now.

    Thanks again for your help.




    Forum Moderator

    Glad to hear that it all worked out for you.

    Hey Doulerner,

    I’m having the same problem that you were having but when it tells me that it’s already exists, it usually replaces the media with a low res picture.
    Very annoying…

    I can run the importer many times and that low res won’t go away.


    Chez Paul,

    I eventually moved on. After running it over and over again until it finally finished I ended up with a state I could “live with.” There may be some images like yours which are a low-res picture. If I find any like that I try to hunt down the original and replace it.

    I don’t think there is anything else which can be done.


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Import doesn't seem to be finishing – I think’ is closed to new replies.