Support » How-To and Troubleshooting » Import Blogger: Unable to login

Import Blogger: Unable to login

  • I’m trying to import my posts from Blogger using the Import > Blogger feature in WP 2.0. When I enter my username & password in the importer it errors out with: Failed to connect to Permission denied.

    Any ideas? I have CURL enabled and I can log into the Blogger site. Thanks…

Viewing 15 replies - 1 through 15 (of 25 total)
  • I have another problem.

    I want to set up a blog with an email address that I have previously used at WordPress but cannot rememeber where I used it.

    How do I cleanse WordPress of my past?

    What does that have to do with my topic?

    Hopefully someone has some ideas for this one…..

    You don’t specify whether you’ve upgraded to 2.0.2 yet; I tried with my 2.0.1 install, and was able to log in. If you get the password wrong, you get an “invalid password” screen, not an “access denied” message.

    Have you tried this again? Maybe Blogger was having some problems?

    I’ve upgraded to 2.0.2. I still have the same issue as of about a minute ago.

    Any ideas?

    I have the same problem. My webhost (Yahoo) automatically imstalls all WP updates, so I guess I’m also using 2.0.2. Whenever I try to login to the importer with my Blogger ID, I get this message “Login failed. Please re-enter your username and password.” I definately have entered my info correctly,so. . . What to do?

    Addict – just to make sure I understand. You can log in as admin to your wordpress blog, but it is the blogger import that’s giving you the error? Is your error message same as HannahIm’s?

    Yes I can log into the WP Admin. I can also log into Blogger without issues (via the Blogger site).

    There’s two error message that appear in the blogger import.
    One at the very top that says:
    Failed to connect to Permission denied

    And one near the username/password fields that says:
    Login failed. Please re-enter your username and password.

    I can only offer two guesses.

    1) The interface to blogger for importing has changed and WP is out of date.


    2) Blogger is blocking access to the interface.

    Hopefully somone brighter will wander by.

    That was kind of my thinking. Guess we’ll see if anyone else has an idea.

    It looks like it may be a web host issue. Apparently they don’t allow socket connections to remote hosts. Sucks for me.

    Here’s a simple PHP script that can be used to test this.

    $ch = curl_init();

    curl_setopt($ch, CURLOPT_URL, "http://www.google.com/");
    curl_setopt($ch, CURLOPT_HEADER, 1);
    curl_setopt($ch, CURLOPT_VERBOSE, 1);
    curl_setopt($ch, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
    curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)');

    $result = curl_exec($ch);

    echo '<pre>INFO';
    echo '</pre>';

    echo '<pre>RESULT';
    print htmlentities($result);
    echo '</pre>';

    echo '<pre>CURLERR';
    echo curl_errno($ch) . ' ' . curl_error($ch);
    echo '</pre>';

    echo '<pre>CURLVERSION';
    echo curl_version();
    echo '</pre>';


    Just thought I’d post back to this in case anyone else has this same issue. I imagine my web host isn’t the only one that doesn’t allow remote socket connections.

    I am having the same problems as Addict — anyone working on this? I’d love to finally flee Blogger and fully transition to WordPress.

    Also, being a novice PHPer, can you tell me how to “run” that script testing the socket connection?

    Copy the text (from <?php to ?>) and paste into a file. Name the file test.php. Upload it to your server. Access it via your web browser (http://www.yoursite.com/test.php).

    It will show you the output.

    Apologize in advance if this is a repeat, but I’m a novice too and having trouble importing from blogger. I’m still getting the “Please enable the CURL extension for PHP and then reload this page” message, even after my host/provider said they enabled curl for me. They said CURL support enabled, CURL Information libcurl/7.10.5 OpenSSL/0.9.7b zlib/1.1.4.

    Any ideas why it’s not recognized? I just installed wp yesterday, so assume it’s the latest version… Thanks.

    Addict, I ran the script as you suggested, and it gave me:
    CURLERR7 Failed to connect to Permission denied
    CURLVERSIONlibcurl/7.15.1 OpenSSL/0.9.7d zlib/1.1.4

    Do I have a similar socket connection issue as yours? And, if so, is there no way around it?

    What worked for me when I had import problems was to do the import to a local PC server. The idea is to import to your own server and then copy the Database as described here http://codex.wordpress.org/Moving_WordPress. See this thread http://wordpress.org/support/topic/60220?replies=4.

    I still haven’t gotten around to copying those posts to my real blog since I also started working on a photo importer to go with it here http://notions.okuda.ca/wordpress-plugins/blogger-image-import/.

    I really should get around to proving out this technique by actually copying my DB tables to my real WP blog. I just never have the time. It is still a viable idea though.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Import Blogger: Unable to login’ is closed to new replies.