Support » Plugin: Link Library » Import and export links – link upload template doesn’t include tags

  • Resolved maurelius

    (@marcuscake)


    Hi Yannick

    I have used the csv import (links) file template to assemble a large amount of links.

    I just noticed that the tags feature you added recently may not be included in the import/export function. There is not a column for tags in the template.

    Is this likely to be changed in future?

    Is there another way to import the links into link-library. I notice the links are stored in wp-posts so I guess its not simple to do a manual import.

    Most grateful for your help!

    Kidn regards

    • This topic was modified 3 months, 3 weeks ago by maurelius.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    Indeed, it is true that tags are not present in the Link Library import and export functions. I can definitely add support for this in the next week or two. I am currently travelling abroad for work, so do not have a lot of time to work on this right away.

    As you say, since Link Library uses custom post types, you could use other importers to bring in data into the plugin (e.g. https://wordpress.org/plugins/wp-ultimate-csv-importer/). That being said, doing this will require you searching through your database to figure out the names of all of the custom fields that are used to store link data.

    Please consider donating to support this plugin’s development.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    I got some free time during my trip and was able to add the functions to export and import tags for links. Please update to latest version and let me know if this works as expected. Please consider donating to support this plugin’s development.

    Thank you!

    I did try the “Export all links” button (to give me a file template) and it responded with a blank screen and the words “can’t open file”.

    I haven’t tried the import because I need a file template to follow.

    I have checked file permissions etc (full permissions). I can confirm that I have successsfuly used the “xport all links” button/function before.

    • This reply was modified 3 months, 2 weeks ago by maurelius.
    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hmm… I don’t understand what I could have changed that would make this not work anymore on your site. I ran tests on my development web server and I can export links without any issues. Could you perhaps add a few lines to your site wp-config.php to enable debugging to a log file? That might give us a better idea of the issue.

    Edit wp-config.php and look for:

    define( 'WP_DEBUG', false );

    Change that line for:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    After you do this, a file called debug.log with all site errors will be created under your site wp-content directory. Open this file and look at the end for errors related to Link Library. If you already had that file enabled before and there is a lot of stuff in it, you can delete it, then go back to press the export button to get a fresh short log with the errors.

    Once you have that info, send it my way. Thanks.

    Your instructions were followed.

    There was a permission error for wp-content/uploads/LinksExport.csv which was the subject of a debug.log error identified on line 1838 in link-library-admin.php .

    For reasons unknown, the file ownership of that file was root:root and 640 . The rest of the directory was the website user and 777. A root web directory ownership and permissions change before, but not sure why it didn’t impact this file.

    After changing the ownership and permissions of this file, the “Export all links” button worked successfully. If the file exists (and can’t be overwritten because of file permissions) then the error above occurs.

    The import/export works as expected.

    In some of the exported links there are characters that cause an extra column(s) to be inserted in the CSV row. The offending charcters in the URL may be # 0 3 8 (without spaces). This might be a quote. It meant that the exported spreadsheet needed to be exported and manually corrected for these characters causing CSV row errors. After being reimported, the links in the library are clean of the offending characters. Although, it may be that the library titles can’t have a quote in them, because of the CSV export error. Not sure, but thought I should politely offer feedback and experience.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Thanks for the update. Indeed, quotes in link names can cause problems when exporting the list of links. Can you confirm that tags could be properly exported and imported with the new version? Please consider donating to support this plugin’s development.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.