WordPress.org

Support

Support » How-To and Troubleshooting » Import 60MB WXR file result in failure

Import 60MB WXR file result in failure

  • I am tring to import a 60MB+ WXR file from a WPMU database into my singleuser WP and it does not work as well as I would like 🙂

    I get to the part where I can choose to assign the posts and once I click next it imports roughly 1000 posts and then throw a 500 Internal Server Error.

    I have seen som referenses to som mysterious 2MB limit, but nothing about where such a thing would be set or how to change it.

    I have made all the changes in the server root php.ini and it makes absolutlely no difference.

    I have tried to locate a WXR splitter, but there does not seem to be a working version out there as far as I have seen (I run Windows 7).

    Any advice would be welcome because I do not want to sit down and split 65.500+ pages of raw XML data into 60+ blocks of XML files….

Viewing 6 replies - 1 through 6 (of 6 total)
  • have you tried running the importer again after it stops – oft times it will pick up where it left off

    Multiple times 🙂
    I appreciate the tip though 🙂

    It seems that the old WPMU database is a 2.6.3 version…could that make a difference?

    <!– generator=”WordPress/2.6.3″ created=”2010-02-18 21:22″–>
    <rss version=”2.0″
    xmlns:content=”http://purl.org/rss/1.0/modules/content/”
    xmlns:wfw=”http://wellformedweb.org/CommentAPI/”
    xmlns:dc=”http://purl.org/dc/elements/1.1/”
    xmlns:wp=”http://wordpress.org/export/1.0/”
    >

    Hello Mortfiles,
    I just literally just authored a WXR file splitter for Windows! It’s only modestly tested, but it does appear to work fine — well, for me anyway.

    If you’d like to give it a shot, I’d appreciate any feedback.

    You can find the download here: http://www.rangerpretzel.com/content/view/20/1/

    Cheers!

    Hi there! In order to import bigger WXR file you should first change max upload size which in your case is 2MB. To do this you need to find php.ini file in your hosting and edit it: just put 100MB instead of 2MB. That`s all.

    Hi, Ranger – your WXR splitter worked like a charm where all other measures (php.ini, advanced export and such) failed. Thanx so much – I converted my 2.6.-single-WP-blog with 600 posts to a WP3.0-buddy-press -community within two hours 😉 The standard import modul needs work, though – the export has improved much with 3.0.

    Greetings from Germany – Gabi

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Import 60MB WXR file result in failure’ is closed to new replies.
Skip to toolbar