WordPress.org

Support

Support » Plugins and Hacks » iMP Links and 2.3 compatibility

iMP Links and 2.3 compatibility

  • iMP links is (was) a great link page plugin – but it’s not working with 2.3.1 (link2cat and categories problems). The authors site isn’t even loading for me (inmypad.com) and I wondered if anyone had a quick hack to make this plugin functional again with the 2.3 branch?

    Here’s the full error:

    WordPress database error: [Table 'wp_link2cat' doesn't exist]
    
    SELECT DISTINCT cat_ID, cat_name
    FROM <code>wp_link2cat</code>
    LEFT JOIN <code>wp_categories</code> ON (<code>wp_link2cat</code>.category_id = <code>wp_categories</code>.cat_ID)
    WHERE 1=1
    ORDER BY cat_name ASC

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • intricateartist

    @intricateartist

    Does anyone have a fix for this plugin?

    evenglen

    @evenglen

    I’d like a fix too. Cause I use it and I love it. But I don’t know if the author will ever get his site back online.

    The site’ll never back again. Hardi has got the job.

    I just saw this and I have the same issue, except that when I desactivate the plugin, I am left with another error message on my page:

    Fatal error: Call to undefined function: imp_links() in /home/milk/public_html/st/wp-content/plugins/exec-php/exec-php.php(39) : eval()'d code on line 3

    I have even tried to delete the plugin, but it hasn’t made no difference.

    To anyone who’s interested, I have a quick fix (well, not really but it’s close enough for me) tutorial that I have posted on my blog.

    Does anyone have a copy of Imp, lost mine during a HD crash

    Thanks in advance

    I’ll check my backups when I get home tonight. I’m pretty sure I still have the copy that I hacked up for my own use, but I may also have a copy of the original.

    *crosses fingers*

    Thanks Nitallica, I appreciate it

    @blloyd, why do you need this? If you’re using WordPress 2.3 and above, it won’t work.

    Anyways, I’ve uploaded, it’s a single file plugin, you can get the plugin here, and CSS here.

    Thanks Rok, I want to see if I can make it work in 2.3
    I liked it better than the rest of the link lists for WP

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘iMP Links and 2.3 compatibility’ is closed to new replies.
Skip to toolbar