Support » Plugin: Cookies and Content Security Policy » Immovable policy link

  • Resolved oriolorive

    (@oriolorive)


    Good morning,
    I’m really satisfied with your app result but I have an issue to solve. When the user visit my site, there appears the cookies popup offering different options. One of these options is to read the Cookies Policy. I select the page where I have the Cookies Policy into “Settings” and “Cookies Policy Page” but it doesn’t works… another issue is that my site was made in different languages, so I would like to offer this link in different languages. Is it possible, how may I solve it?
    Thank you so much in advance!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Johan Jonk Stenström

    (@jonkastonka)

    Hi!

    Did you add it in /wp-admin/options-general.php?page=cacsp_settings&tab=settings under Cookie policy page?
    What is the link you’ve added?

    To add the link in different languages, just translate it in your multilanguage plugin.
    From the FAQ: Polylang and WPML

    Thread Starter oriolorive

    (@oriolorive)

    Thank you Johan, In the drop-down I select the page where I have the legal notice (including Cookies) in English. This page is …https://xxxxxx.com/en/legal-notice/. But when a user goes to my site and see the cookies popup, the link of the cookies popup always redirects to the same pages where the user is. For instance if you visit http://www.xxxxxx.com the link shown is http://www.xxxxxx.com and if you go to http://www.xxxxxx.com/en/products the link shown is http://www.xxxxxx.com/en/products. So the user also enters in a kind of bucle.

    Plugin Author Johan Jonk Stenström

    (@jonkastonka)

    Yes, that is because the link is empty <a href="">Link</a>. I could see the page /en/legal-notice/ on your site, and when I go to that page, the modal appears. That tells me that it’s not the page set as Cookie policy page, since that page shouldn’t show the modal.

    Please double check that setting on /wp-admin/options-general.php?page=cacsp_settings&tab=settings

    Thread Starter oriolorive

    (@oriolorive)

    When I go to
    /wp-admin/options-general.php?page=cacsp_settings&tab=settings
    I check the selected Cookie policy page with the drop-down button and I select the:
    /en/legal-notice
    It doesn’t works. It seems as it doen’t detects my selection.

    Plugin Author Johan Jonk Stenström

    (@jonkastonka)

    I did a fresh install, just to make sure it works, and it works.

    What multi language plugin are you using?

    Thread Starter oriolorive

    (@oriolorive)

    I’m using Polylang and Elementor. What a pity… I want to use your plugin because is really the best… jejeje thank you so much Johan!! 🙂

    Plugin Author Johan Jonk Stenström

    (@jonkastonka)

    So, if you go here: /wp-admin/admin.php?page=mlang_strings&s=cacsp_option_settings_policy_link&group=cookies-and-content-security-policy&paged=1 you should see a string for that value that is the ID of the cookie policy page. Is there something there? And, if so is it the right ID?

    Thread Starter oriolorive

    (@oriolorive)

    I get it!! The problem I had is that when I change the “legal-notice” page I must go to the chain translation to update all links with the code number that the cookies plugin associates to each page. Now is clear and, as far as I know it, easy to manage.
    Thank you so much Johan!!

    Plugin Author Johan Jonk Stenström

    (@jonkastonka)

    Great to hear you got it sorted!

    If it’s not too much, please consider leaving a review. 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.