Support » Plugin: dsIDXpress » img src missing closing > on listings

  • Im trying to test your plugin and we are seeing a typo in the outputted code. The listing results img tag is missing a closing >. This is on all listing results, single multiple, and the idx listing pages.

    http://pastebin.com/2L6fDCw1
    Line 3 shows the img tag, and line 4 continues without the closing IMG tag, resulting in this mess: http://cl.ly/ZsPB

    I searched the code but cant find where this HTML is and we cant continue without this being fixed.

    I am demoing Version: 2.1.18 on a test account. my client wont likely sign up under the current conditions

    https://wordpress.org/plugins/dsidxpress/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author LindzConnell

    (@lindzconnell)

    Hello Matt,

    We’re not able to reproduce this issue on our end using various different themes. Generally, when an issue like this presents there is either something within another plugin that’s causing the issue or something, more likely, within the theme itself.

    You can test this by switching your theme to something like Twenty Twelve and you’ll likely see that the issue resolves itself.

    Once you’ve confirmed that the issue is within the theme itself (or another plugin) you’ll need to debug the issue within the theme’s code itself.

    Here are some screen shots showing the product working properly on other sites:

    http://prntscr.com/69q1vi
    http://prntscr.com/69q3ji
    http://prntscr.com/69q4r2
    http://prntscr.com/69q6gm
    http://prntscr.com/69q71m

    Please let us know if you have any additional questions, Matt.

    Thank you,

    Lindz Connell
    Diverse Solutions Team

    Thanks.
    Okay so it is our theme.

    But i have never in my 8 years of developing custom themes see a theme break the HTML output of a plugin. My pastbin shows that the IMG tag is clearly not closed.

    Any ideas how thats possible?

    So this is really strange. We are using foundation for our grid, and foundation has:

    img {vertical-align: middle;}

    If i add to our css:

    img {vertical-align: inherit;}

    all is well.
    That has to be the strangest thing i have seen in a long time.

    Actually that didnt really fix it, and on closer inspection running the 2015 theme, we still have the same code issue of the img src missing the closing >.

    The vertical align css just moves the overhanging html to no longer been seen with the overflow:hidden on the ds-media div.

    The HTML view source from this plugin still shows a missing > regardless of the theme.

    Plugin Author LindzConnell

    (@lindzconnell)

    Hi Matt,

    We’ve not gotten any reports from our live customers with the same issue so that tells us that it’s related to something in your specific environment.

    It could be another plugin that’s causing the issue since you don’t believe it’s the theme.

    If you haven’t already done so, try deactivating all plugins but dsIDXpress. Then, check to see if the issue still exists. If it does NOT exist then you’ll know the issue is related to one of your plugins. Then, activate all other plugins one at a time. After activating, check to see if the issue happens. In this way you should be able to locate the offending plugin.

    Let me know if you are able to figure this out!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘img src missing closing > on listings’ is closed to new replies.