Support » Plugin: Postie » IMAP Error: Can't open Stream

  • Resolved Jonas

    (@jhuesser)


    My settings:

    Protocol: IMAP-SSL
    TLS: yes
    Port: 993

    Login Informations are correct.

    If i test my config I recive this message:

    Warning: imap_open(): Couldn’t open stream {[servername]:993/service=imap/ssl/tls/novalidate-cert} in *\wordpress\wp-content\plugins\postie\postieIMAP.php on line 89

    and

    Unable to connect. The server said:

    Line 89 in postieIMAP.php says

    $this->_connection = imap_open($this->_server_string, $login, $password, NULL, 1, array('DISABLE_AUTHENTICATOR' => 'GSSAPI'));

    So what did I wrong?

    https://wordpress.org/plugins/postie/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Essentially that error means that Postie could not talk to the email server. Either the server name or port is wrong or the host is blocking the port.

    Hmmm I didn’t figured out a solution yet. tried it with different ports and protocols. Login informations are true and server shoulden’t block the ports.

    Plugin Author Wayne Allen

    (@wayneallen-1)

    There is something blocking the communications. There are many people using IMAP successfully. Have you tried turning TLS off or just using POP?

    Yeah, turned TLS off and on. SSL too.
    Tried all different Ports.

    If I use Pop3 it says:

    Unable to connect. The server said:POP3 connect: Error [10060] [A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    ]

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Have you confirmed with your host that the port isn’t blocked? Many shared hosting vendors block ports.

    Yes. It’s the site for the company I’m woriking for, so we are the host. The port is not blocked.

    Maybe it helps when I metion, that the mail server runs on an exchange server.

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Can you ssh into the server that has Postie on it and test the connection?

    netstat -ln|grep -E ':::(993|995|143)'

    or

    telnet <host> 993

    I’m having a very similar problem. Here is my netstat:

    1171911@p12:~$ netstat -ln|grep -E ':::(993|995|143)'
    1171911@p12:~$

    Here is my configuration:
    IMAP, no TLS, port 143, server imap.gmx.com

    Plugin Author Wayne Allen

    (@wayneallen-1)

    No output from netstat means the port is blocked. Talk to whoever manages the server and/or firewall.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘IMAP Error: Can't open Stream’ is closed to new replies.