Support » Plugin: Buoy » IMAP connection Failure

  • Resolved bmead65921

    (@bmead65921)


    I am having connection issues with my imap server. I use Yahaoo’s small business hosting plans and sometimes it runs into issues. I turned on debugging but really all it tells me is that I have an authentications issue:

    Tue, 03 Jan 2017 21:44:32 +0000
    Connection to: imap://imap.mail.yahoo.com:993/
    Connection failed: Error connecting to server.

    [03-Jan-2017 21:44:32] Error connecting to mail server.

    [03-Jan-2017 21:44:32] Scheduling WP_Buoy_SMS_Email_Bridge run for post ID 71 at Tue, 03 Jan 2017 21:45:32 +0000 (back-off step is 1)

    [03-Jan-2017 21:44:42] PHP Warning: fopen(/dev/urandom) [function.fopen]: failed to open stream: Operation not supported in /3upkansas/wp-includes/random_compat/random_bytes_dev_urandom.php on line 57

    [03-Jan-2017 21:44:42] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Error reading from source device’ in /3upkansas/wp-includes/random_compat/random_bytes_dev_urandom.php:145
    Stack trace:

    #0 /3upkansas/wp-content/plugins/buoy/includes/class-buoy-alert.php(454): random_bytes(1048576)
    #1 /3upkansas/wp-content/plugins/buoy/includes/class-buoy-alert.php(417): WP_Buoy_Alert->get_random_seed()
    #2 /3upkansas/wp-content/plugins/buoy/includes/class-buoy-alert.php(215): WP_Buoy_Alert->make_hash()
    #3 /3upkansas/wp-content/plugins/buoy/includes/class-buoy-alert.php(1328): WP_Buoy_Alert->set(Array)
    #4 [internal function]: WP_Buoy_Alert::handleNewAlert(”)
    #5 /3upkansas/wp-includes/class-wp-hook.php(298): call_user_func_array(Array, Array)
    #6 /3upkansas/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(”, Array)
    #7 /3upkansas/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #8 /3upkansas/wp-admin/admin-ajax.php(91): do_action(‘wp_ajax_buoy_ne…’)
    #9 {main} thrown in /3upkansas/wp-includes/random_compat/random_bytes_dev_urandom.php on line 145

    I am able to connect several different platforms to connect in with these same settings but they don’t seem to want to work here. It requires SSL and I have tried all three settings yet still same failure. Kind of at a loss on what to look at next.

Viewing 4 replies - 1 through 4 (of 4 total)
  • PHP Version : 5.3.6
    PHP Memory Usage: 33.29 MB
    PHP Memory Limit : 256M
    PHP Max Upload Size : 50M
    PHP Max Post Size : 50M
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off
    PHP Allow URL Include : Off
    PHP Display Errors : On
    PHP Max Script Execution Time : 90 Seconds

    Plugin Version : 4.0.7
    WP Version : 4.7
    WPMU: No
    MySQL Version : 5.1.55
    WP Table Prefix : asb_
    PHP Version : 5.3.6
    Session Save Path : /tmp
    WP URL: http://itstopeka.com/3upkansas
    Server Name : itstopeka.com
    Cookie Domain : itstopeka.com
    CURL Library Present : Yes
    Debug File Write Permissions : Writable

    As I am looking at this a little closer and with fresher eyes, it looks to me as if it is the fopen() call that is failing because my Yahoo host does not allow fopen() and has php_flag allow_url_fopen off.

    I am seeing that it is recommended for security reasons to turn this off and for remote file access, consider using the cURL functions that PHP provides.

    I am not a PHP developer so no clue what to do in this instance. I doubt I am able to enable fopen() before the call and then disable it after the call since this is hosted on a Yahoo server and wouldn’t even knw where to do this at. Any ideas?

    Plugin Author Meitar

    (@meitar)

    Yahoo’s mail server only supports TLS connections. Use Buoy’s “Force TLSv1.2 (recommended)” setting.

    The fatal error is addressed in Buoy 0.3.4. Either apply this patch or update to Buoy 0.3.4 when generally available.

    Plugin Author Meitar

    (@meitar)

    Here’s the “official” patch, which has now made it to the Buoy development repository (instead of my own hotfix).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘IMAP connection Failure’ is closed to new replies.