Support » Fixing WordPress » Images won't upload…

  • Whenever I try to use drop and drag, or choose file I get the following message:

    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    and no image. My image is 940 X 198 pixels and about 200 kb, so it isn’t empty.

    Any advice would be most helpful. I have just upgraded from 2.6 to 3.41


Viewing 15 replies - 1 through 15 (of 19 total)
  • esmi


    Forum Moderator

    What browser are you using? What happens when you use the Browse uploader?

    I am on a Mac; tried Chrome, Firefox and Safari, and got the same “empty” file message. Tried it with both the drag and drop or the Browser uploader…no success. The only way I could change the header image was to upload it manually and then add it to the CSS for the header.

    But this is cumbersome for everyday blogging and uploading images. I also got this same message when I tried to add images to the media library.

    any thoughts?



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    did all of those things, including trying the Twenty Eleven theme…
    When I am trying to upload an image within a post, nothing happens.
    When I try to use the drop and drag feature I still get this message:

    “” has failed to upload due to an error
    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    I have tried multiple different jpegs and pngs…none works and I can’t add media to the media library, I get the same message.

    the only way to get an image up is to upload it manually and then point to its URL.

    But thank you for your suggestions!!



    Forum Moderator

    What happens if you try using another machine? Or a PC?

    Have no other machine…but I found the php.ini file on my server ( my site is hosted by Hostways,) and changed the upload from “off” to “on”.

    Now I have a new error message!! Progress, yes?

    Unable to create directory /home/c/6/9/21965/21965/public_html/metamoments/wp-content/uploads/2012/07. Is its parent directory writable by the server?

    any suggestions for this one?

    again, thanks for your help!!



    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    Okay…tried all of those and nothing good happened. I did loose the header photo I had brought in by hand tho…go figure…

    still getting this message…

    Unable to create directory /home/c/6/9/21965/21965/public_html/metamoments/wp-content/uploads/2012/07. Is its parent directory writable by the server?

    any other thoughts…is there some other file I should change the permissions on?

    Have you checked to be sure you have an uploads directory in wp-content/uploads ?

    If you have the uploads directory but not the year month, try creating them and give 755 permissions, and try to upload again, if that doesn’t work try 777, and see if it does.

    Yes I was wondering about that too, so I created uploads, 2012, and 07 and gave them permissions of 777 but got exactly the same message back.

    I was wondering where the directory path was generated and if it might be incorrect in the earlier stages, ie, the part that says “/home/c/6/9/21965/21965/public_html/”–

    any other thoughts?

    and thank you for chiming in and helping with this…It is kind of basic functionality, but without it, I might as well just resort to pointing to images with my html, and that kind of defeats the purpose of all the new fangled cool things about this new version of WordPress…!!

    That does seem like an ‘odd’ url … have you asked your hosts?
    Usually there is a ‘password’ or user id in the space where you have “6/9/21965/21965/”
    Did this start to happen with the 3.4 upgrade?

    Do you do an incremental upgrade going from 2.6 to 3.4.1?

    I didn’t do an incremental upgrade. I just went for it. Do you think that was a mistake…?
    I probably will need to involve the folks that host my website but I was trying to avoid that– They upgraded the php and mySQL for me just prior to my doing the WordPress upgrade…

    So do you think it is too late to do anything to undo what I’ve done by going for the 3.4.1? I do have a back up of the old 2.6 files? I could reinstall those and then upgrade by increments? could I? Are those upgrades still available? Any recommendations?

    thanks again for thinking this through for/with me…

    More information…I can create posts just fine. And yesterday I added a page no problem. But when I went to activate the Facebook,, plugin I got this message:

    Parse error: syntax error, unexpected ‘/’ in /home/vg010web06/17/64/2926417/web/metamoments/wp-content/plugins/facebook-twitter-google-buttons/facebook-twitter-google.php on line 105

    Don’t know if this is at all helpful but it does seem like something is funky with the directory path.

    Any thoughts?

    Last piece of information…when I created a path.php file, the directory path I got was

    which is really different than the one WordPress is generating…any thoughts about why it is generating an incorrect directory path?


    I do believe it makes a difference in upgrading to jump major releases.
    Did you review Upgrading_WordPress_Extended
    Before you started?

    Detailed Upgrade Instructions for 1.5.x, and versions 2.0 – 2.6.5, to 3.4.1

    The following are the instructions that explain the above steps in more detail. Please read all of the instructions before starting.

    If you plan on upgrading across more than two major releases, please consider upgrading incrementally to avoid potential conflicts. For example, if you plan on upgrading from 2.5 to 3.4.1, upgrade to 2.7 first, followed by 2.9, and finally 3.4.1. Essential, it’s okay to skip one release, but never skip TWO when upgrading.

    You say you have a back up of the 2.6 files did you also take a database backup? Without that you don’t really have your content.
    And you should back up what you have now in case you didn’t keep your database.

    Also check these forums, the last few days I have seen several people with a very similar problem, and somehow they are all related to something happening on their hosts server (Blue Host I believe).

    Have your urls always been numerical? I still think you should talk with your hosts.

    I have also read on these forums of several people who upgraded to 3.4 who had problems, did down grade successfully. Perhaps that is what you need to do, then to incremental upgrades, with total back ups in between, and testing plugins and themes, so you will see where the issue starts. Sorry I don’t have a better idea.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Images won't upload…’ is closed to new replies.