Support » Fixing WordPress » Images Won’t Load Until I Refresh

  • Resolved epiphany770

    (@epiphany770)


    I have a few pages on my site with images. When I try to view them on my laptop (that I am building the site on – I haven’t used any other computers), the images don’t load unless I refresh the page. This only happens on my own computer, it seems to be working fine on other computers and laptops.

    The issue exists on both Safari and Chrome. I’ve cleared caches on both. SiteGround said they thought it was a network issue, but it happens both at home and at work.

    Are there any other solutions? I’m not sure why this is happening only on my laptop.

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • mishagen

    (@mishagen)

    I have visited your website and it seems work fine. Maybe thre is something wrong in your computer. To be sure we need to test your website from other computer first. This type of erros could be because your internet conection is really slow or you have something in your computer whose avoid its load but i’m not sure.

    epiphany770

    (@epiphany770)

    I asked my host (SiteGround) to look at it and they said it worked fine when they opened the link. I also had a friend try it and it worked for them and it works fine on my phone.

    I know it’s an issue related to my computer, I just don’t know what it would be. I don’t know if there is some other cache I need to clear that I don’t know about.

    And it’s not the internet, because the same issue occurs at work or at home.

    mishagen

    (@mishagen)

    Sometimes antiviruses or firewall programs act so restrictively that they can cause what they describe. It is not common but possible. Have you tried to disable them temporately? just in case 🙂

    epiphany770

    (@epiphany770)

    I don’t have any programs like that on my laptop.

    The images on the home page show up for me… But images on the About pages that I uploaded myself do not show up until I refresh. Not sure if that makes any difference!

    epiphany770

    (@epiphany770)

    Now this issue is happening on my mobile and PC. So… not sure what’s going on. Could it be the host I’m using?
    This is super frustrating.

    Hello epiphany770,

    I understand your frustration here.

    When I opened the Homepage, the image loaded just fine, but when I explored inner pages, I started facing the same issue you are facing.

    On the Portfolio page, there was no image, I check the HTML code by inspect element and found the image source is missing.

    I think the problem is somewhere in the theme used, can you please try by switching to default theme once and see if image loads.

    Let me know your response.

    Thanks.

    epiphany770

    (@epiphany770)

    The only images I’ve uploaded are on the pages under “About”. So the Portfolio page is still set up as it was for the theme demo.

    I’ve contacted the theme support. In the meantime, if I do switch to a default theme, will that remove all of my settings in the theme I’m currently using?

    Sorry, I’m still pretty new to WP!

    Thanks! 🙂

    epiphany770

    (@epiphany770)

    Update: I disabled JetPack and that seems to have solved the issue with images not loading properly. I’m having issues with plug-ins not working correctly (pop-ups and drop-downs), but I think that’s a compatibility issue with my theme (Stockholm).

    Hey epiphany770

    Good to know that the problem got resolved.

    You can discuss with theme support on why some plugins link jetpack is not compatible with their theme.

    Thank you for sharing this with us.

    I had the same issue. If you would like to continue using Jetpack, I disabled “Lazy Load” in the performance settings, which appears to have fixed the issue on my end.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Images Won’t Load Until I Refresh’ is closed to new replies.