Support » Plugins and Hacks » Images Won't Delete

Images Won't Delete

  • In WP 3.9.1, works well with one exception: when I delete media from Media –> Library by clicking “Delete Permanently”, the browser simply goes completely blank and the image is not deleted either from the WP database or S3. I’ve confirmed the IAM user has delete privs. Error is: “[26-May-2014 15:49:56 UTC] PHP Fatal error: Class ‘XMLWriter’ not found in /var/www/mikedunn.me/wp/wp-content/plugins/amazon-web-services/vendor/aws/Guzzle/Service/Command/LocationVisitor/Request/XmlVisitor.php on line 201”



Viewing 9 replies - 1 through 9 (of 9 total)
  • Still an issue in the latest version. Anyone else able to delete images from the Media Library?

    Delete is working fine for me. What is your IAM user policy so I can investigate and try to recreate?

    Thanks. I’m just allowing full S3 access to the user’s group:

      "Statement": [
          "Effect": "Allow",
          "Action": "s3:*",
          "Resource": "*"

    Just managed to delete ok with the same group policy. What version of the Amazon Web Services plugin are you using?

    Looks like 0.2.


    Hi Mike

    Is the WP site running on AWS at all? Have you got an IAM user with a group applied? Can you try adding just a policy to the user?

    It is. It’s running on EC2 (Amazon Linux). I removed the user from the group and applied the S3 full administrator policy, but still the same result. Here is the entry in the Apache error_log:

    PHP Fatal error: Class 'XMLWriter' not found in /var/www/mikedunn.me/wp-content/plugins/amazon-web-services/vendor/aws/Guzzle/Service/Command/LocationVisitor/Request/XmlVisitor.php on line 198

    Installing php-xml fixed it for me.

    php-xml fixed it.


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Images Won't Delete’ is closed to new replies.