WordPress.org

Forums

Images Won't "Delete Permanently" or "Replace Media" (3 posts)

  1. csybesma
    Member
    Posted 1 year ago #

    I am having trouble updating media files with new versions. Due to organizational reasons, the media file name is exactly identical to what was previously uploaded to my site.

    When I click "Delete Permanently" the image disappears like it should, but when I then upload a new version of the file that has the same exact file name, the old image shows up again.

    When I try to "Replace Media" it allows me to go through all of the steps, and I can see that I am choosing to replace the image with an updated version that I have saved locally, but then the image on the site remains unchanged.

    I can only replace the image if I upload it as a new file name, which I do not want. It seems like my wordpress is caching the images somehow.

    Your help is VERY much appreciated!

  2. kmessinger
    Forum Moderator
    Posted 1 year ago #

    Delete media just takes it out of the library. To actually delete you need to go to wp-content/uploads and delete.

  3. sootsnoot
    Member
    Posted 1 year ago #

    Authors/editors of a site within a multisite network don't normally have direct access to the uploads folder. So if the network admin has enabled space quotas, it seems like this behavior would leave them no way to reclaim space. Once they uploaded enough media to fill their quota, they'd be stuck.

Topic Closed

This topic has been closed to new replies.

About this Topic