Support » Fixing WordPress » Images uploaded but invisible

  • I’ve spend the last 8 hours figuring out what’s going on with my media library. I tried everything from setting permissions etc.

    So here’s my problem;

    I recently moved my WP to a different host. While still on the development newly uploaded images presented fine on the page and thumbnails were visible. After migrating from the development domain to the production domain, newly uploaded image thumbnails and page media do not display. I can upload an image, although WP doesn’t create a month folder. I created one manually but no success either.

    Does anyone have a solution?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Permissions and/or ownership are certainly a possible cause. The other thing to look at is the actual file paths which were being used on the development server and are now being used on the production server. The fact that you’re not seeing the correct folders created when you upload an image could be due to either permissions/ownership or file path problems.

    To solve the problem quickly, you need good data. The first thing I would do is get access to the server error logs on the production server to see if there are any errors being generated that would point to the problem.

    To rule out permission/ownership issues, you can use a file manager if your host has a good control panel, or an FTP program. On a linux-based web host, the files typically have an owner/group corresponding to your user name. The folders whould have permissions of 755 and the files 644.

    Be sure to check your Media Settings for the upload folder path to make sure that’s correct for the production server.

    Hi Linux4me2,

    Thank you for your super fast reply !!!!
    I’ve been checking my ftp (i use a simple ftp program called fetch).

    As i check permission settings:
    it’s set on 770. Meaning owner and group have all options checked and Others have none.

    uploads & 2012
    it’s set on 750. Meaning same settings as wp-content accept for ‘group’ can’t write.

    For instance folder 10 is also set on 750 which has always worked before. 11 is empty now and as said before map 12 hasn’t been created by WP but i tried manually later deleted it as it didn’t change anything..

    Hope you get what i’m saying and know some way to help 😉

    Hmm… I don’t get those permissions at all. That means the public has no read or execute permission on your wp-content, uploads, and 2012 folders. It’s really odd that it was working for the 10 folder, too, unless that was before you moved to the current host. This is a Linux-based server, isn’t it?

    I would start by contacting your web host and asking them what the correct permissions for WordPress/web folders on their server should be. If they aren’t correct, the web host could easily run a command from a shell prompt–which you may not have access to–to reset the folder permissions to the correct values in one pass.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images uploaded but invisible’ is closed to new replies.