Support » Fixing WordPress » images upload but only insert as links.

  • Resolved CyruzDraxs


    I recently updated from 2.2 to 2.3 and ever since images have no longer inserted properly. When I upload an image it uploads fine to the correct directory and creates thumbnails properly too, but after it’s uploaded I get to the part where it asks how II want to insert it. It used to list Full Size, Thumbnaiil and none in addition to the linking details, but now that isn’t displayed and now when I click Send To Editor it creates a link instead of an image.

    When I upgraded I made sure to disable and re-enable all the plugins. But that doesn’t really even matter because, even without any plugins enabled, it still inserts images as links.

    If I go into the Browse section of the image uploader, instead of displaying my previously upload images, it just shows blue boxes with the title tag in it. Even on images that previously displayed fine.

    When I insert it and it appears as a link it IS linking to the correct location, which really confuses me, because obviously it knows the correct location, it’s just ignoring the fact that it is an image for some reason. :S

Viewing 1 replies (of 1 total)
  • Disregard that. Problem solved.

    Comment out line 613 of podpress.php.

    //add_filter(‘get_attached_file’, ‘podPress_get_attached_file’);

    I was sure I tried it with podpress disabled, but I guess I must’ve been hallucinating. >.>

Viewing 1 replies (of 1 total)
  • The topic ‘images upload but only insert as links.’ is closed to new replies.