Support » Fixing WordPress » Images upload but no thumbnails or preview

  • osunick


    I downloaded WP 2 today and got it running. It appears to work fine in all respects except for the image uploading. First of all, I only get an “Upload” tab under my text editor on the “Create New Post” page. I can select a jpg to upload but nothing happens. No thumbnails or confirmation of any kind. The only way I can verify that the files are being uploaded are by browsing down the wp-content folder hierarchy (into year then month). So the files are uploading but I’m not getting the thumbnails or image browser that I hear everyone talking about.

    Surely, I’m not supposed to remember the url’s and type wp-content/uploads/2006/01/blah.jpg in order to embed them manually, should I?

Viewing 15 replies - 1 through 15 (of 21 total)
  • gornik321


    Have the same problem. Do you need any special php extentions? I have mbstring, gd2, mysql.
    apache 2.0.55
    php 5.1.1
    mysql 5.0.18




    Posting here because my problem may be related.

    After upgrading to WP2 I had to re-upload the post images and edit my posts, adding the images back in.

    I edited maybe 30 posts, happily uploading images and adding them to posts from the panel.
    For some reason the menu you get when clicking on the thumb stopped working, it’s not there anymore.
    So I can upload images and see the thumbs but nothing else, no linking or deleting.

    If I click the “next” button from “browse all”, those thumbs can I delete/link and such, the menu is gone from the firsts “page” of thumbs only.

    When it happened I figured it was a FireFox error, but after clearing cache, restarting and trying Opera, I guess not.

    Does anyone have a solution to this? Where are information about the images stored?

    Hm, I tried editing another (previous) post, there I get the menu when clicking a thumb from the list, maybe I uploaded a corrupt image after?



    osunick and gornik321, do you have imagemagic installed?

    As for my problem, it looks like I uploaded an image that was broken in some way.
    Now, if I only can find out how I can safely remove the images from WP, I see them referenced in the wp_postmeta table.

    @class: don’t have imagemagic installed.
    I get a successfull upload and the thumbnail but stull no “browse all” tab.

    gornik: Can you look in your posts table and see if there’s anything with post_status=’attachment’?

    there are no post_status=’attachment’!
    But I found out what was wrong? I have MySQL 5 installed. Had the same problem with drafts.
    I just edited the wp-includes/functions-post.php on lines 299 and 322 where I inserted a IGNORE in the SQL line.
    299: “UPDATE IGNORE $wpdb->posts SET
    322: “INSERT IGNORE INTO $wpdb->posts

    hope this helps

    This was an incredibly helpful post. I had read that this was fixed (reported as a bug) on 12/24, and replaced my functions-post.php file with the fix, but still images wouldn’t work. I could see that they were uploading when I checked the uploads directory (under year and month), but they were not showing up in the browse. I was just getting a series of MySQL errors (running MySQL 5.x).

    I made the two little changes to the fuctions-post.php file, and viola. Thanks!

    Updated to WP 2.0.2 today and the same thing happened again. I changed these lines in wp-includes/functions-post.php:
    300: “UPDATE IGNORE $wpdb->posts SET
    323: “INSERT IGNORE INTO $wpdb->posts
    and every thing started working.

    I just open page Write->Write Post and then click Browse to select a picture and then upload.

    I’m running Apache 2.0.55, PHP 5.1.1, MySQL 5.0.18.

    Thought this was fixed in the new version of WP.

    I’ve added those two amends to the code, but my uploads are going directly to wp-content/uploads and not wp-content/uploads/2006/04 – the original and thumbnail are being created, but uploaded to the wrong place!

    Is there anyone who can help a newbie figure out this solution? My pictures are uploading but they do not show in my browse menu or my posts either. I do not know html but if you walk me through this, I might be able to figure it out! I looked for line 299 and 322 but maybe I’m not counting right? There didnt seem to be the same codes there? I’m lost and doing this myself. Please help!

    I’m another newbie struggling with the same issue. The WP image loader did nothing when I tried to use it.

    I read elsewhere that some are solving the problem with a plugin called Image Manager, but I’m getting a 550 server error message and no images posting, though they are uploading. I’m going to ask the developer for uninstall instructions now as they are so far unable to suggest a solution to several of us stuck with this error.

    My blog was migrated 48 hours ago and I’m still trying to re-load the images. I’m just not finding the instructions I need to get this done. Where should I look next?

    I just went back to my blog and find that now the WP image process is working. It does add the image to the post, but it is not copying the image to the WP directory, which would be my preference rather than relying on images remaining on-line from their source. Any ideas?

    I am having similar problems with getting images to show up on my blog. I uploaded a couple of images and created thumbnails. They show up in the browse and can transfer to the editor. When I publish and look at the blog, the thumbnail doesn’t show up, but the title of the image does. It’s a link and when I click on it, a 500 error occurs.

    Heres the url:

    Please can you go to the site, click on the jpg link and see what’s happening?

    I already put the IGNORE in both statements as recommended. Nothing changed. I’ve tried ImageManager plugin and it doesn’t work any better, but seems for different reasons.

    I’m so frustrated with WordPress right now. I hear it’s the best engine, but for as long as I’ve been using it, and for several different blogs, I’ve always had problems with what should be very simple things. arg.

    I would appreciate any help or suggestions with this image problem.

    Make sure that the …wp-content/uploads directory exists and has the correct permissions.

    I’m still struggling with this to no avail. I’ve deleted/recreated the wp-content/uploads folder, set it to 777 and tried to upload. The file uploads, but no subfolders (year/month) or thumbnails are created. The file appears in “Browse All” as a text link only.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Images upload but no thumbnails or preview’ is closed to new replies.