WordPress.org

Forums

images upload but dont show (30 posts)

  1. mart29
    Member
    Posted 6 years ago #

    Hi, ive really struggled with this, running macOSX and have the latest version of flash, i have tried using the browser uploader thing too.
    The images do upload but they dont show, i get a blue square with a question mark in it and that is all.

    any ideas why?

    thanks

  2. whooami
    Member
    Posted 6 years ago #

    any ideas why?

    nope.

  3. myinstinctwaswrong
    Member
    Posted 6 years ago #

    URL?

  4. mart29
    Member
    Posted 6 years ago #

    thanks for your reply:)
    http://www.kayeefong.com

  5. whooami
    Member
    Posted 6 years ago #

    youre uploading .tiff files

    tiffs are NOT images files that are browser friendly.

  6. mart29
    Member
    Posted 6 years ago #

    Hi, i see why that appears to be the case, because open image in new window link says so..but they are all 100% all of them, .jpg files.

    THey appear in manage>media library as .jpg files as well.
    The images are also not viewable in the media library. just the blue squares.

  7. whooami
    Member
    Posted 6 years ago #

    well then, LOOK at your source:

    <img src="webkit-fake-url://AD2F2253-9928-495F-826A-6D9834C6DCFB/image.tiff" alt="" />

    thats a tiff being called. so either its a tiff, or your link is wrong. And in fact, THAT link is wrong. Thats not a valid URL.

  8. mart29
    Member
    Posted 6 years ago #

    so what am i meant to do with that?
    the image is uploaded by wordpress to my webserver, i can see it there and download it and its correct.

  9. mart29
    Member
    Posted 6 years ago #

    im using the From Computer>choose files to upload option.
    So it should be adding the correct url itself seeing as it manages to correctly upload the picture in the first place, right?

  10. flashpal
    Member
    Posted 6 years ago #

    mart29,

    Do you have a FTP program like WS_FTP or Filezilla? I also need to know if you have an image editing program where you can open those TIFF files and convert them to JPG files.

  11. mart29
    Member
    Posted 6 years ago #

    hi there, yeah they are already .jpg files, they are showing up as .tiff but i dont know why, they have always been and are on the webserver, i use cyberduck for ftp and on there they are .jpg files too.

  12. myinstinctwaswrong
    Member
    Posted 6 years ago #

    @mart29: You are missing the point

    if they have a .tiff file extension, they are not .jpg files. If they are, then they are named incorrectly.

    You either need to rename them to .jpg files - which will NOT work if they really contain .tiff data.

    OR

    You need to use some program to open the .tiff files, and then save them back out as .jpg files - then upload those and it should work fine.

  13. mart29
    Member
    Posted 6 years ago #

    i understand what you are saying but they are literally labelled as .jpg on the webserver, and appear as such in manage/media library.
    there is no where i can change them to .jpg files as they already are. on the webserver and in the media library section of wordpress they appear as (for example) image12243.jpg

    its only in the link when you click show in new window that they appear as .tiff and i have no idea why. they have never been .tiff and appear nowhere else as having a .tiff extension, i hope that makes sense.

  14. flashpal
    Member
    Posted 6 years ago #

    mart29,

    Could you give me the direct URL to one of your pictures? For example it would be something like http://kayeefong.com/wp-content/uploads/2008/08/image12243.jpg

    It would help if I knew if you're a newbie to building a website, because I don't want to come across as flip. An URL is basically nothing more than an address. If someone is from the USA, that's their country, if they're from Illinois, that's their state, Chicago is their city and 12242 Maple Street is where their house is. In other words it would be like http://usa.com/illinois/chicago/maplestreet/12242.house :-D

    In the same vein, the Internet is the same way. kayeefong.com is your country, then the "/" slash mark leads to where your pictures are in your country. Again, I'm not being flip or trying to be condescending, I was a newbie once that helped me understand.

  15. mart29
    Member
    Posted 6 years ago #

    yeah im new to it. ok i tried to make a link but it wont show, it wont even link to the wp-content folder. yet the all the text is showing.

    WordPress has uploaded the pictures to the wp-content folder. let me say that im not using an ftp program to do this im using the builtin feature in wordpress to select a file from the computer for upload.

    Not sure why that is happening, when i connect with an ftp client i can see the pictures have been uploaded, i can download them with the ftp client and they are the correct pictures.

    any further ideas? thanks for your help.

  16. flashpal
    Member
    Posted 6 years ago #

    OK, mart, it seems as if you're having some type of internal server error. I typed http://kayeefong.com/wp-content/uploads and got the message: The server encountered an internal error or misconfiguration and was unable to complete your request.

    So something is amiss. It could mean a lot of things, but first contact tech support at your host provider. If, for example, you bought your site from godaddy.com, contact them and give them that internal error message.

    I first put http://kayeefong.com, which functions right, then I added /wp-content, which returned a blank page as it should (it's a blank index page that protects your files from being seen), but as soon as I added /uploads, that's when I got the internal server error message.

    Check tech support at whoever you bought you site space from and maybe it's an error on their part causing your problems.

  17. mart29
    Member
    Posted 6 years ago #

    hi flashpal, there was a security problem abd that has been resolved so thank you very much for that. however, its still not working but it niw generayes an error message which is:
    EXCEPTION: message: Undefined value
    EXCEPTION: line: 96
    EXCEPTION: sourceURL: http://www.kayeefong.com/wp-includes/js/swfupload/swfupload.js?ver=2.0.2-20080430
    EXCEPTION: name: TypeError

  18. mart29
    Member
    Posted 6 years ago #

    i needed to change the settings for upload to the correct directory, for some reason the default directory was set to wp-content and not wp-content/uploads. no idea why but anyway, its working though it does stll give that error. but thanks to everyone.

    any comments on that error message would still be appreciated. but thanks especially to flashpal. :)

  19. flashpal
    Member
    Posted 6 years ago #

    I took a look, your pictures are loaded and it looks good. I didn't see an error message on the page. Does it happen when you're editing? If it's not appearing anymore when you're editing, then I'd say the error was merely due to the wrong default for the uploads. I actually searched that error message and only found one other person it happened to, someone on a German WordPress site. The exact same file and error message. What he did, I don't know since I can't read German. :-D I'm glad it's working for you now, but let me know if the message is still popping up when you're trying to blog.

  20. mart29
    Member
    Posted 6 years ago #

    HI Flashpal its only when pics are being put up in the add media add image bit, at the bottom there is a box where error messages can come up. the same message is still coming but as far as i can tell its not having any effect as such, which means im not that bothered by it.

    Dont suppose you know how to make the whole blog a bit wider do you?

    But thanks for your help, it wouldnt be working otherwise.

  21. ben_allison
    Member
    Posted 6 years ago #

    i'm experiencing the same problem

    i'll upload images, they'll be ok for a bit, then wp will change the image links to a "webkit-fake-url" url, and change the file name to "image.tiff."

    What gives?

  22. ben_allison
    Member
    Posted 6 years ago #

    Anyone?

  23. myinstinctwaswrong
    Member
    Posted 6 years ago #

    what browser software do you use?

  24. ben_allison
    Member
    Posted 6 years ago #

    firefox 3.

  25. myinstinctwaswrong
    Member
    Posted 6 years ago #

    hmmm, ok, probably not what I thought then. If you google the "webkit-fake-url" you will find several hits - one is reference to a webkit bug. If you google "webkit" you find lots of hits, but basically, look here http://en.wikipedia.org/wiki/WebKit

    It is the basic framework for several browsers including Google's Chrome among others.

  26. MikeGusto
    Member
    Posted 6 years ago #

    My site (formatmag.com) is now having this problem as well. Did anyone come up with a solution?

  27. JoshRoseman
    Member
    Posted 6 years ago #

    I am having a similar problem. I kept getting this error:

    Unable to create directory /wp_uploaded_files. Is its parent directory writable by the server?

    I have made the directory as well as everything else on the site 755 permission. However, I continue achieving FAIL. I even tried creating a new directory and giving it 777.

    http://www.11aliveblogs.com
    WP 2.6.5

    Any ideas?

  28. isangi5
    Member
    Posted 6 years ago #

    I am also having problems like this.

    can I ask where could I find a way to change the default directory ? I think that is the case because when I uploaded through file manager in wp-content/uploads it doesn't appear in the library

    Thanks

  29. astromono
    Member
    Posted 6 years ago #

    I have a similar problem as well, I am able to see the image and I am able to edit it, but only when I upload it for the first time.

    So, say I upload two images for a post at the same time. I can edit one of them and put it in the post, but when I go to "Insert image > Gallery" to insert the second image, I can't because nothing happens when I click on the "Show" link next to either image.

  30. johnmee
    Member
    Posted 6 years ago #

    Same problem resolved...

    I forgot I'd added an ".htaccess" file.
    My .htaccess had a typo.
    It said "<FileMatch>" where it should've said "<FilesMatch>".

    <FilesMatch "\.(php|htm|html)$">
    Deny from all
    </FilesMatch>

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.