Support » Plugin: NextGEN Gallery Optimizer » Images Still Loading Slowly

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi Alicia,

    Thanks for downloading NextGEN Gallery Optimizer Premium!

    I’ve just had a look at your site, and I believe the reason your images are loading slowly is because of their large file sizes (which is due to them having unnecessarily large dimensions and lacking any compression)…

    The images in the “Residential/HOA” gallery are 1333x1000px, which is actually larger than most displays will accommodate. For example, my large 17-inch display set at a maximum resolution of 1440x900px, still needs to scroll to see them in full. In addition, each image is over 1MB in size, which will take any file many seconds to transfer (depending on your connection).

    NextGEN Gallery can actually handle both of these aspects for you automatically when uploading. You just need to select the “Scale images to max…” checkbox on the upload screen. The values can be customized at Gallery –> Options –> Images, however I find the default 800x600px and an 85% image quality to be the sweet spot between good load times and an attractive display.

    For your existing galleries, you can also use this automatic resize functionality retroactively. Simply navigate to Gallery –> Manage Gallery, click the select all checkbox next to the ID column title to select all your galleries, and using the “Bulk actions” drop-down menu, select “Resize images” and click the “Apply” button. In the pop-up lightbox that follows, just enter your preferred maximum dimensions (NextGEN will respect the aspect ratios), click “OK” and all images in all your galleries will be resized.

    Alternatively, if you’d like a bit more control over the process, you could always use image editing software such as Adobe Photoshop before uploading (in particular their fantastic “Save for Web” optimization feature). I usually shoot for a file size no larger than 200kB.

    I hope this helps!

    Cheers,
    Mark.

    Hi Mark,
    Thank you for your response!
    I remember reducing the file size through the manage gallery option, but I must not have “saved changes” because, you’re right, all the images are gigantic.
    I have since changed and saved all file size to the 800 px you recommend, but it still seems as if there is a 2 second pause between scrolling through images. Is there anything else I can do? Thank you for your help!
    Alicia

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi Alicia,

    No worries. That’s looking much better! 🙂

    If you want to take things further, I have two suggestions…

    1. I would recommend using a Content Delivery Network, which will serve images (and other static files) to customers more quickly (by being geographically closer to them and by reducing the load on your server). Personally, I use Amazon CloudFront integrated via W3 Total Cache.

    As the site’s for a local business however, it might be even faster to host it right in Colorado where the customers are based.

    Here are a couple of good articles on the topic if you’re interested…

    http://artoftravelblogging.com/how-to-install-amazon-cloudfront-and-why/
    http://www.nextgen-gallery.com/cdn-jetpack-photon/

    2. You could try some dedicated image optimization plugins. Both of these use lossless optimization techniques…

    http://wordpress.org/plugins/wp-smushit-nextgen-gallery-integration/
    http://wordpress.org/plugins/ewww-image-optimizer/

    I hope this helps!

    Cheers,
    Mark.

    Hi Mark,
    Thank you so much, you’ve been a great help! I am looking into these two suggestions…much appreciated. I am still learning so much.
    Thanks again!
    Alicia

    I can mark this topic as “resolved!”

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi Alicia,

    You’re very welcome. I’m glad I could help 🙂

    All the best with your site!

    Cheers,
    Mark.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Images Still Loading Slowly’ is closed to new replies.