Support » Networking WordPress » Images smaller than 8kb not served from blogs.dir

  • Resolved jmaxlow

    (@jmaxlow)



    Just upgraded WPMU 2.9.2 to WP 3.2.1. Everything seems to be working well except for one perplexing issue – images from the blog directories that are smaller than 8kb are not accessible through the web. This is a problem because when I add an image to a post, the default smallest auto-generated thumbnail usually ends up being less than 8kb, resulting in broken images in posts. Even direct web hits to the files themselves result in failures, though direct web hits to the greater than 8kb versions are successful even though they are in the exact same directory with identical permissions.

    I’m running PHP 5.2.9, MySQL 5.1.32, and Apache 2.2.11 on Windows 2003 Server. I also have memcached running. This problem did not occur prior to the upgrade from 2.9.2.

    Here’s an example of an image smaller than 8kb: http://community.nn.k12.va.us/test/files/2010/09/Winter-100×75.jpg

    Here’s an example of an auto-generated thumbnail of the same original that is larger than 8kb:
    http://community.nn.k12.va.us/test/files/2010/09/Winter-300×225.jpg

    What could be going on? The issue does not come up outside of the blogs.dir subdirectories, so I think it may be tied to some combination of rewriting, caching, and permissions, but I checked configuration files for everything I could and I see no reference to minimum file sizes that might cause problems.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Interesting. http://community.nn.k12.va.us/test/files/2010/09/ itself has the same problem.

    Did you upgrade your .htaccess file as needed AND flush the memcache?

    I flushed the memcache through a memcached plugin, but it had no effect. I ended the memcached service, reloaded, no effect. Deleted the plugin and switched to W3 Total Cache, set it up to work with memcached, no effect. And then about two hours into experimentation, the images started to be served again. Bizarre!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I flushed the memcache through a memcached plugin

    A WP plugin or a server one? memcache on your server is usually a weird thing, and it SHOULD dump itself every 24 hours (on average).

    Whaou jmaxlow, please could you tell me how you upgraded your MU 2.9.2 to the last version of WP because I’m finding different versions on the net and I’m pretty scared of doing something irrevocable (even if I backup all with Xclone).

    I have WPMU 2.9.1 and in fact I’m really surprised that the developers (who are doing an excellent and wonderful project that I love of course) let this bug in this stage: the upgrade button is not working and there is no way to easily upgrade the script (forbidden what ? back to the stone age of the internet or what !!??)

    I’m surprise because I have intentionally waited for the 3.2 because it was supposed to offer different options for upgrades. And there is nothing there except more trouble.

    Like many, I used MU to offer free blogs to my community and I really don’t want to mess up their sites/blogs (and I did the backups…again).

    I dont have enough knowledge to play with a broken database. I really don’t feel secure in modifying the wp-config for NONCE-SALT especially because de documentation is for wordpress 3.0 and not 3.2.1 (supposedly different).

    Again, I was waiting since a long time to switch to the new and unique version of WordPress, the 3.2, now I feel like… abandoned with my old MU and a bunch of people in my back waiting for me… I don’t want to crash the thing…

    Thanks anyway

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    in fact I’m really surprised that the developers (who are doing an excellent and wonderful project that I love of course) let this bug in this stage: the upgrade button is not working and there is no way to easily upgrade the script (forbidden what ? back to the stone age of the internet or what !!??)

    Actually,the developers DID make it so you could upgrade smoothly… to 3.0.

    I’m surprise because I have intentionally waited for the 3.2 because it was supposed to offer different options for upgrades. And there is nothing there except more trouble.

    Dunno where you read anything like that. THere’ sjust the auto-upgrade. Had you gone to 3.0 when it came out, you;d have auto-upgraded from that point.

    You waited so long that now you have to do it manually.

    Follow these steps:
    http://codex.wordpress.org/Upgrading_WPMU

    I really don’t feel secure in modifying the wp-config for NONCE-SALT especially because de documentation is for wordpress 3.0 and not 3.2.1 (supposedly different).

    Not as for as I know. The nonce salts have been the same forever.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    On Nonces…

    IIRC we did add a couple more salts into the API mix with MultiSite. If you were on WPMU 2.x they’re the same. If you went from Single to Multi, at the 3.0 switch, you were alerted to the change. It still works with the old ones, mind you, they’re just less secure a bit 🙂

    I really don’t feel secure in modifying the wp-config for NONCE-SALT especially because de documentation is for wordpress 3.0 and not 3.2.1 (supposedly different).

    Piffle. Yeah, I said it. Changing your salts and nonces is safe as houses and has ONE (yes ONE, singular) ‘catch.’ Your cookies are invalidated and you have to log back in. Oooh 🙂 Nothing to fear here, go do it!

    http://api.wordpress.org/secret-key/1.1/wpmu/salt

    Thank you for your time. Will think about it…

    Ok that’s the revolution:
    http://wpcandy.com/series-on/wordpress-3-2-in-depth
    WordPress 3.2 introduced an update to the automatic updates built into WordPress (you know, the functionality that lets you click one button and update your install) to allow for partial downloads. This meant that when automatically updating your WordPress site, after 3.2, only a partial download (of changes) would be necessary, and not a full copy.

    But nothing to do with updating from other version.

    I think my “so long to update” is not “so long”.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    zedrino, you’re reading way weird into this, man.

    As of 3.2, WordPress uses partial updates. This means ONCE you’ve upgraded to 3.2, and you use the auto update, you will find that WP updates much faster as ONLY the changed files get downloaded. If you’re upgrading from before then, you get the same old full files upgrade, every WP file gets uploaded.

    That’s it. I don’t know where you’re getting confused or het up about it. It’s pretty normal stuff.

    YOU can’t run an auto-upgrade because you’re on version 2.9.x of WPMU is all. For the 3.0 branch, WP made a duplicate of the wpmu named files. Here’s a secret: They were the exact same builds as single site! I know! How cool is that 🙂 The name was different because WPMU looked for wordpress-mu-version and not just wordpress-version 🙂 As of 3.1, I believe, that was dropped since if you’d skipped 3.0, it’s better to manually go from 2.9.2 to 3.0 to 3.1 anyway.

    You right you right, that’s good and normal, no problem. Don’t want to upset nobody.

    Then you suggest me to manually update the WPMU 2.9.1 to WP 3.0. Then I suppose I can do automatic upgrade from 3.0 to the last version with the magic button.

    thanks for your help.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I wouldn’t.

    I would do 2.9.2 -> 3.0 -> 3.1 all manual, and THEN do 3.2

    Remember WP, like Apple, uses major releases (2.x to 3.x) to indicate massive fundamental changes, and point releases (3.0 to 3.1) to mark big changes, while second point (3.2.0 to 3.2.1) to indicate minor fixes. So there’s a LOT that changed between 3.2 and 2.9, and you may want to do some testing of themes and plugins in between 🙂

    Why this is not existing any more in the wp-config.php ? thanks

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);
    define(‘VHOST’, ‘yes’);
    $base = ‘/’;
    define(‘DOMAIN_CURRENT_SITE’, ‘exemple.com’ );
    define(‘PATH_CURRENT_SITE’, ‘/’ );
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOGID_CURRENT_SITE’, ‘1’ );

    Ok I think I did everything and then the only result is that:

    One or more database tables are unavailable. The database may need to be repaired.

    Should I go to the link http://mybrokensite.com/wp-admin/maint/repair.php?referrer=is_blog_installed

    Any suggestion ?

    Sorry,

    I just add the
    define(‘DB_COLLATE’, ”);
    define(‘VHOST’, ‘yes’);
    $base = ‘/’;
    define(‘DOMAIN_CURRENT_SITE’, ‘exemple.com’ );
    define(‘PATH_CURRENT_SITE’, ‘/’ );
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOGID_CURRENT_SITE’, ‘1’ );

    to the config and it’s much better…of course..

    All done, whaou so nice ans so easy. You are great !

    Still have this on the dashboard Thank you for Updating! Please visit the Update Network page to update all your sites. With the link not working. All sites are running 3.2.1

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Images smaller than 8kb not served from blogs.dir’ is closed to new replies.