WordPress.org

Forums

[resolved] images running over end of posts (5 posts)

  1. cthunman
    Member
    Posted 4 years ago #

    Hey guys, I'm having a bit of an issue where my posts are cutting off, and the picture inside them sometimes runs over into the next post. I am using the 2010 theme, and my site is here at http://www.thewcpress.com/

    The best example of this is the post about making your own maori tattoo, which is accessible by itself here: http://www.thewcpress.com/?p=181 In either place, you can see that the image runs over the bottom border and messes up some of the stuff below.

    Any thoughts?

  2. MarkRH
    Member
    Posted 4 years ago #

    Oh yeah.. that image has a float:left style on it and the article content isn't long enough to clear it. You need to add a style="clear:left;" or style="clear:both;" to the first thing below that post.. which looks like the Facebook Like DIV or add a <br style="clear:left;" /> at the end of the post to make sure it clears that image.

  3. cthunman
    Member
    Posted 4 years ago #

    Is it possible to make this change in the style.css file? I'd like it to automatically fix this problem in future posts as well.

  4. MarkRH
    Member
    Posted 4 years ago #

    Well, the following might work in your specific case: In your theme's style.css try adding the following at the end of it:

    #wp_fb_like_button {
       clear: both;
    }

    As long as you have the Like button as the first thing after your post, that should do it for every post.

  5. cthunman
    Member
    Posted 4 years ago #

    Thanks, this worked pretty nicely. I appreciate the help.

Topic Closed

This topic has been closed to new replies.

About this Topic