Support » Plugin: External Media » Images on Google Drive don’t display

  • Hello,

    I have reviewed the Support Forum and followed up on several suggestions, and have done my best to follow your directions, including activating the Google Drive API. As you can see from the link, the published page displays the clickable link text, which when clicked, does display the proper image. I am using Ubuntu 14.04 / WP 4.9.5 on the AWS infrastructure.

    Process:
    1. Open page for editing in WP. OK.
    2. Click “Add Media” link, Add Media window opens. OK.
    3. Click “Insert from URL” link, URL entry box appears. OK.
    4. Copy and paste shareable link to image from Google Drive. OK.
    5. Click “Link to Google Drive” button, Drive logon flashes and “Insert into Page” link becomes active.
    6. Click “Insert into Page” button, return to post edit page, with link text added. OK? I’d expect to see the image here, but will continue.
    7. Publish page. OK.
    8. View page. Not OK; page displays active link to expected image, not the image.

    Suggestions?

    I have tried this same process with a Team Drive; it doesn’t get even as far as inserting a valid link. I’d really like to be able to use this plugin with Team Drive, as has been mentioned in another post. Thanks for any input you can provide.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author minnur

    (@minnur)

    Hello @dvhirst865 it looks like that image has some privacy settings in your google. Have you tried to import it instead of just liking to it ?

    Please note that Insert from URL feature does not generate an image tag, it just creates a direct link to a file on your google drive.

    Thanks,

    Minnur

    Thanks for the quick reply and the suggestion. I’ll check into it and come back with any additional information I can find.

    I’m back after verifying that the Drive folder in use can be linked publicly. I’ve made two visible pages, one edited with Cornerstone. The result is completely non-functional. The second one is edited with the WP editor, not Cornerstone. It still exhibits the behavior mentioned above; link text is visible, and links when clicked to the appropriate image. The image does not display automatically in the WP Page, which is still what I need. Also, the first time I tried to open the image, I was required to login in; how can I stop this from occurring?

    I’d welcome your suggestions.

    • This reply was modified 1 year, 5 months ago by  dvhirst865.
    Plugin Author minnur

    (@minnur)

    @dvhirst865 would it be possible to record your screen and share it with me? I don’t need to see configuration page in the recording. You could just include the screenshot of the page (make sure to hide credentials from it).

    I have a feeling this has something to do with permissions in your google drive. The plugin does not have any integration that would require authentication. I believe that’s google.

    Thanks,

    Minnur

    @minnur, any chance you are still working on this plugin. Understandable if you are not, but it will be missed.

    Plugin Author minnur

    (@minnur)

    @gusreiber I got so busy with my projects I don’t have any free time left to work on any of my open source projects. I will get back to this project when I have more time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Images on Google Drive don’t display’ is closed to new replies.