Support » Localhost Installs » Images not uploading to localhost wordpress 3.3.1

Images not uploading to localhost wordpress 3.3.1

  • I’ve been trying with great difficulty to resolve this issue.
    First, I moved a few sites from the web to my localhost (Mac OS 10.6). I also installed a fresh wp site for testing plugins, etc. All sites have the same problem: the media uploader goes through the motions, shows as a successful upload, generates a url, but the image isn’t there. It has no thumbnail, either. It does not show errors.

    The sites on the web never had this issue, nor have I ran into anything like this, and there are no forum threads showing this specific problem with a solution.

    I went through the applicable troubleshooting steps provided here:

    No luck. Somebody please make my day!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Not sure if this is related but I am also having trouble importing posts from my online sites’ wp-exports.

    I’m seeing the same thing after switching from MAMP to MAMP Pro. I suspect it is a permissions issue. – the Pro version is stricter- Will post more when I figure it out.

    Yes – changing permissions on upload directory to 777 fixed it. I had tried setting local host permissions in Mamp Pro but it didn’t take.

    See the solution here: http://wordpress.org/support/topic/not-uploading-images-on-local-wp-site?

    I was able to use Dreamweaver to change file permissions by setting up the ftp client to view the files in the remote view:

    Host directory: / (/Applications/MAMP/htdocs/ doesn’t work for me)
    Hostname: localhost
    Username: your OSX user account ID
    Password: your OSX user account password

    For me the solution to the problem was to change to “run apache server as user/user” instead of www/mysql as it suggested. Of course, then I had to restart MAMP pro (as in quit the program completely) before it worked correctly. It’s something to try anyway.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Images not uploading to localhost wordpress 3.3.1’ is closed to new replies.