Support » Fixing WordPress » Images not uploading Error

  • Resolved CellaScarpi

    (@cellascarpi)


    Is there a way to just go back to the previous version of WordPress?

    When trying to upload images I receive the following message:
    An error occurred in the upload. Please try again later.

    I tried Deactivating all plugins which I HATED doing cause this site is live and it is the middle of the day.

    Even with No active plugins it still did not work.

    I can not switch themes to see if it is a theme error, so is there a way to just go back to the previous version?

    Or something else I can try because I have got to get this fixed as soon as possible. Thank you.

    http://www.sdwr.org

Viewing 15 replies - 1 through 15 (of 25 total)
  • This is happening to me with Magic Fields 2; seems to be a compatibility issue. I just rolled back by replacing all the wordpress files (except config.php and the wp-content folder) with the earlier version of wordpress, at least until a fix is found.

    Where did you get the files from the previous version?
    I don’t have the Magic Fields 2 plugin, none of my plugins are causing it.

    Moderator kmessinger

    (@kmessinger)

    CellaScarpi – You can install the older version of WP ontop, but we can’t promise it’ll work (which is why we always suggest backups).

    When trying to upload images I receive the following message:
    An error occurred in the upload. Please try again later.

    That’s from the in-line editor, right? What happens if you go to wp-admin/media-new.php and upload there?

    Yes I’ve read through the Master list.

    It was not helpful in this situation.

    The only Plugin I have that should have been affected is Roles but it seems to be working just fine.

    The only thing I haven’t tried, but will not try is swapping back to default theme. My theme is child themed, but I have found no one else posting issues about this with the parent theme… so far.

    @ipstenu (Mika Epstein)

    That worked for uploading the media!

    But I am unable to set featured images, I can post just fine this way using coding once the images are up on my website.

    The Media Library though via insert featured image or image into post shows as being empty, and even adding image via URL does nothing.

    I’ve tested Chrome, Firefox, and IE.

    Chrome and Firfox have this issue. IE doesn’t even open the popup to attempt to add media, and does not show the kitchen sink above the content box for editing posts. (Not that I care about that, I prefer chrome) I figure I’d include this detail in case it can help with figuring out the issue.

    I tried to post screenshots but the links were not working. 🙁

    Found the issue, but I have no way to resolve it that is going to be an easy fix.

    For anyone else wanting to know….

    I started up a new wordpress site for testing, added my theme and problem still existed. Removed my theme added twentytwelve. It worked perfect.

    So here is the problem.

    Several commands that call things into action were changed to work with the new media uploader/ editor.

    One being the way resized images are being called. (If you teach a dog come and then say over here, he won’t come.) So with the calls changing, anytime my theme uses the old commands it does nothing.

    Now the solution options for anyone else with this issue:

    Wait for the Theme you are using to fix the issue (Don’t hold your breath, this could take a while.)

    Start a new wordpress website running 3.4.2 and don’t upgrade until your theme fixes the issue.

    Switch to TwentyTwelve, start from scratch at rebuilding/ redesigning your theme to work for you.

    Sadly the last option is the route I am choosing to take. It’s not gonna be easy, cause I have NO idea where to start, but I’m gonna take it little by little and pray.

    Currently My theme is a child theme of a theme I liked, but then twisted and turned and warped it into my own. So waiting for updates and changes do me very little to no good.

    esmi

    (@esmi)

    Forum Moderator

    Several commands that call things into action were changed to work with the new media uploader/ editor.

    Would you care to elaborate with some examples?

    My theme calls the stock WP “image_resize” function, which has been depreciated in favor of “WP_image_editor::resize”. I would just modify my code to work with WP_image_editor, but there’s no documentation available for it yet. So I am forced to rebuild my theme using TwentyTwelve as the base.
    image_resize isn’t the only function that was depriciated but it is one that has caused issues for my theme.

    image_resize() is deprecated, but should continue to work as it did previously. Backcompat is included.

    There will be more documentation forthcoming, but you can check out the syntax for WP_Image_Editor::resize() here:
    http://core.trac.wordpress.org/browser/tags/3.5/wp-includes/class-wp-image-editor.php#L82

    i cant upload anything either, i tried in the media section and i get this error

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/70/6550770/html/wp-content/themes/gonzo/includes/widget_areas.php on line 154 and defined in /home/content/70/6550770/html/wp-includes/wp-db.php on line 990

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/70/6550770/html/wp-includes/wp-db.php:990) in /home/content/70/6550770/html/wp-admin/async-upload.php on line 32
    21190

    line 154 is

    $widgetized_pages = $wpdb->get_col($wpdb->prepare(“SELECT DISTINCT meta_value FROM $wpdb->postmeta WHERE meta_key = ‘omc_page_sidebar'”));

    esmi

    (@esmi)

    Forum Moderator

    As per the Forum Welcome, please post your own topic. Your problem – despite any similarity in symptoms – is likely to be completely different.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Images not uploading Error’ is closed to new replies.