Support » Fixing WordPress » Images not uploading

  • Resolved tcrock18

    (@tcrock18)


    I can not upload any images to my site. When I try adding a new image either through the media library or through a page it will act as if it is done uploading but it is just a blank square and nothing shows up. In the console, I get a 404 Not Found error and when the page is trying to display the image I get a Failed to load resource: the server responded with a status of 404. When you go into the media library and click on the image it doesn’t display but when you click edit image it displays. The steps I have taken already – 1. Removed all plugins and themes and went back to the original. 2. Updated/Changed .htaaccess file. 3. Changed permissions on the server. 4. Contacted hosting company (GoDaddy) and they said it was okay and they can upload an image from the server so it’s not on their end… 5. Changed the default image uploader in the wp-config.php ( I believe that’s where it was)
    Does anyone know how to fix this issue or more steps I can take to resolve it?
    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • paulswarthout

    (@paulswarthout)

    I had this problem a year or so ago when I first started playing with WordPress. I solved it by increasing the maximum file size that I was allowed to upload. That involves a change to the php.ini file (which you can do through cpanel). Change the ‘upload_max_filesize’ option to be larger than the files that you’re trying to upload. What would happen is WordPress would attempt to upload an image, it would get part way through and then just quit — no error, no message, nothing, just a blank image in the library. After increasing the max upload size, I haven’t had a problem.

    tcrock18

    (@tcrock18)

    @paulswarthout thanks for the suggestion. I made those changes and I am still having the issue, unfortunately.

    tcrock18

    (@tcrock18)

    Figured out the issue. My folder (public_html/uploads/images/11) permissions were set to 700 and not 755. I thought I changed all the folder permissions.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images not uploading’ is closed to new replies.