Support » Plugin: Blogger Importer » images not transferring

  • Resolved wallaby

    (@wallaby)


    i have previously imported my blogger blog into wordpress, but after noticing that the new version of the imported also migrates the images (thank you so much for this feature!) i decided to re-import the blogger posts. i made a work copy of my site and then deleted all the posts and the images from the posts, and then ran the new importer. the posts came in fine, but the images imported a few, and then stopped. the action button says “importing” but i don’t see any progress happening. i let it run for 4 hours yesterday.

    https://wordpress.org/plugins/blogger-importer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Workshopshed

    (@workshopshed)

    Typically when the importer runs for a long time it’s actually erroring but not reporting it back to you.
    Configure logging to file and see what it’s reporting.
    http://codex.wordpress.org/Debugging_in_WordPress

    thanks. i have enabled reporting and i think i see some errors.

    is there some way to upload the log so that you can take a look?

    the site in question is: http://www.3groupinc.com/sl4000

    i disabled all themes and plugins other than the blogger importer and twenty fourteen to see if there were any issues.

    Plugin Author Workshopshed

    (@workshopshed)

    Best way would be to take snippets from the file. Alternatively you could try pastebin.com

    i figured out why i was getting errors. in my case, there was a small icon image that was a broken link. once i fixed that issue, the blog transferred correctly. i found that by trial and error – looking at the last post that had transferred correctly. it would be cool if the error report could show that it was a broken link.

    thanks for your help and also thanks for a fabulous plugin. i have been wanting to move the blog off of blogger for quite a while, but didn’t want to leave my pics on the blogger servers.

    Plugin Author Workshopshed

    (@workshopshed)

    Thanks for the update, will try to modify the code so that it does not stop in this scenario. Can you describe the nature of your broken link?

    it was just a dead image link, but it was a small social icon, so i didn’t realize it was missing. the html was asking to load an image but the image had been moved or deleted. the plugin seemed to hang because it didn’t know what to do in that case.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘images not transferring’ is closed to new replies.