Support » Fixing WordPress » Images not showing up in Safari (Mac and IOS) but fine in Chrome

  • Hi all, I have been searching for this issue all night and every other topic that toches on this does not fix the issue. I have the latest WordPress version running and have cleared cache on-site and in the browser, no change. I have a disabled caching plugin, no change.

    One topic suggested an issue with SSL but that does not seem to be my issue. Permalinks should be fine as images load in Chrome, no Firefox.

    Any help would be much appreciated. Pulling my hair out!


    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • fancyscientist


    I am having this problem too. I tried everything in this thread except I did not clear my entire CloudFlare cache – just the webpages that had problems. Do I need to clear everything? Cloudflare doesn’t recommend this.



    It is also not recommended to have a website with broken images 😉

    You need to purge the Cloudflare cache completely.

    is there one click option to reformat webp into original jpg or png format ?
    formated images into webp using SG optimizer ,
    but iPhone safari browser does not show webp image file ,
    is there one click option to reformat webp into original jpg or png format ?
    or do i need to re-upload all the images , bummer !

    I’m having the same issue, I have purged cache on Cloudflare and my server. Still no luck.

    What is the status of your SSL certificate on your server (so NOT Cloudflare’s SSL)?

    Is the SSL certificate on your server still valid?

    If not, issue a new SSL certificate for your server.

    After that, purge all caches including Cloudflare.

    Also: Do you have mixed content (both SSL (secure) + non SSL (insecure content))? If so, you should fix that too to solve this issue.

    @caged Our server doesn’t used mixed content but still some css and images not loading in IOS/MAC safari browser, but everything fine in chrome or other browsers. Please share you input and thanks in advance.

    This is generally a mixed content error. The images are being served http and your site is loading https. Browser security will flag the images and not display them. There’s a few things you can try.

    • If you’re actively developing try to changing the URL in the browser from https to http.
    • Develop locally on your machine
    • Force https if your site is live
Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.