Support » Fixing WordPress » Images Not Showing Up after Uploading

  • So I updated to 3.1 and tried to upload an image. The image uploads but you can’t see it in the little edit preview window. You can click into edit the picture and see it. Once you try to place the image into the post you only see a black outline of the image and the image does not show.

    I have tried reloading 3.1.
    I have deactivated all my plugins and it still does not work.
    I have tried uploading via FTP to image gallery and you still can’t see the image.


Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi


    Forum Moderator

    Check your uploads path in Settings->Media

    Hi, I have the same issue with version 3.1.

    I notice this is an issue with security. Even if the upload folder has read write permission this is not propagate to the child with IIs 7. If I manually put read access to the file WordPress is able to read it succssfully.

    Where I can modify to let WordPress save the file with at least read permission?



    Forum Moderator

    @horseman4: It is considered impolite to try and highjack another poster’s thread. Please post a new topic.

    I’m sorry, I’ll do.

    I post here because I think my problem maybe the same of this thread and may help both to fix his issue.

    any answers? It is impolite to hijack a thread? I would love to see some help on this, since both seem related to me.

    Ocala Website Designs


    Yeah, really esmi, if you didn’t flame him without helping anybody, i would now have the answer to my problem. Now I have to keep looking and the guy had the intelligence to look at permissions and is using iis. It could be related as I have a similar problem, you can upload the image, but don’t have permissions to access it. You can access the other images that WordPress automatically cuts out from the one you uploaded, but not the orginal uploaded one…

    Ocala Website Designs


    From David Hassen – Technical Blog
    Computing ‘How to’ WordPress Upload Permission problem on IIS 7
    Problem: When uploading files through the WordPress interface (either via add media or attaching to a post), IIS can’t seem to read the file properly, more specifically serving the file. The IUSR account has the correct permissions on the uploads folder, the file is actually on the server when inspected. Anonymous authentication is enabled, fastcgi is correctly impersopnating, and IUSRS group also has the correct settings. Even the network service account has permissions on the uploads directory. The problem still persists! The directories have cascading / inherited permissions set, but when a file is uploaded, the file in question doesn’t inherit the permissions – they are granted some ‘special permissions’ for the network service account also. I assumed there was a problem with the network service account permissions etc. Not so….

    Solution: Check the temp uploads folder that PHP uses. In my php.ini file on IIS, I have file_uploads = On and specified a folder location at upload_tmp_dir = <directory location>

    Check that the directory exists, and make sure that the IUSR account has modfy permissions on the folder.

    Reason: When php uploads files, it stores them in a temp directory for loading. When you upload a file using wordpress, the correct accounts need the appropriate permissions, otherwise the file doesn’t get written to the desired location with the correct permissions.
    I haven’t tested it but it fits …

    Ocala Website Designs


    That’s the problem but the solution is a little off. I made the setting for the tmp folder in the php.ini for the server and in the specific website ini and it wouldn’t work. Seems it still wanted to use the windows/temp folder even after a reboot.

    IIS_USR is already in the permissions for the windows/temp folder so I just added ‘read’ to the temp folder permissions for that account. Voila, uploaded an image in WordPress and the permissions worked.

    Thx Horseman for getting the ball rolling for me. Hope I wasn’t Hijacking this thread or whatever… The image doesn’t show cause you don’t have the permissions to see it…

    @ocala Website Designs,

    Thank you so very much for coming back and saying what your solution was!

    Changing my permissions on windows/temp so that IIS_USR could access it fixed everything! I’d been looking for a solution to this for a month at least…

    You’ve made me very happy!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Images Not Showing Up after Uploading’ is closed to new replies.