WordPress.org

Support

Support » Multisite » [Resolved] Images not showing up after migrating from individual blogs

[Resolved] Images not showing up after migrating from individual blogs

Viewing 15 replies - 1 through 15 (of 22 total)
  • Did you setup your .htaccess correctly?

    I believe so; it’s a direct copy-and-paste from the Network Setup instructions.

    Oh, darn. Thought it had public DNS. I’ll check when I get back from lunch.

    Nope. I get a 200 with a content-type of image/jpeg and a content-length of 11506, but nothing shows up. (The content-length in the old site’s response is 33723.)

    Any other ideas, anyone?

    Sorry, I was sick yesterday.

    I would think something’s not set up correctly in the new account. The .htaccess not redirecting usually means mod_rewrite isn’t set up with enough allow overrides going on to let it double jump. Which is probably still the case with ms-files. Make sure that your httpd.conf file lets both the old domain and the new one use allowoverride set to ALL.

    /etc/apache2/httpd.conf is empty and /etc/apache2/apache2.conf doesn’t have any AllowOverrides. The only relevant AllowOverrides I can find (which I believe are set correctly) are in /etc/apache2/sites-available/default:

    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    
    	DocumentRoot /var/www
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>
    Options FollowSymLinks Indexes MultiViews
    AllowOverride All
    		Order allow,deny
    		allow from all
    	</Directory>
    
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
    
    	ErrorLog /var/log/apache2/error.log
    
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    
    	CustomLog /var/log/apache2/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>

    I tried manually replacing an image that hadn’t been showing up, and it worked. Do you think it might be faster to do that than to keep trying to figure out why the automatic migration isn’t working for images?

    See “AllowOverride None”?

    That’s possibly it. It should be “AllowOverride All”

    I changed that and restarted apache, but it didn’t fix the problem. “AllowOverride None” is only under directories that aren’t used by WordPress, anyway (the server root, /usr/lib/cgi-bin, and /usr/share/doc/); the one that is relevant (/var/www/) has been “AllowOverride All” this whole time.

    In your post I saw this:

    DocumentRoot /var/www
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /var/www/>

    Which is why I pointed it out.

    Yeah; I saw that, too, but changing that to AllowOverride All didn’t fix the problem.

    It seems like the faster way to go will be manually re-uploading the images. It’d be nice to have an algorithmic solution in case others in the future have a similar problem, but for me, today, that doesn’t seem very realistic since I need to get the whole thing up and running ASAP.

    Thanks so much for your help, Ipstenu; even though we haven’t optimally solved the problem, it’s great that there are people like you who help people like me without really asking anything in return.

    If you import/export it should have brought the images over (and re-uploading makes … no sense as a fix o.O)

    Yeah, import/export did bring the images over, but only to the filesystem; they wouldn’t show up online. I’ve already finished re-uploading all of the recent images, and they are showing up now. I’m not sure why it works, just that it does work.

    I will certainly agree, though, this whole issue seems to make very little sense at all.

    See that’s what doesn’t make sense.

    If the images were copied over to the filesystem, then … they’re there. You know? The filesystem is /www/blog-new/wp-content/blogs.dir/1/files/etc right?

    Are you having to reimport the images to the media admin page or just FTP them back up?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Images not showing up after migrating from individual blogs’ is closed to new replies.