Support » Fixing WordPress » Images not showing on website!

  • There is no problem uploading images to my media library.
    Featured images in backend post/pages were all inserted.
    But no images are showing live on my website posts or pages for some time. Just grey blocks!
    I’ve been with WordPress now for about four years. Only having the problem now (for about three months)
    I thought maybe WordPress had a problem and they would correct things in time. But no such luck.
    I’ve gone through all the support threads but none seem to answer this problem. They have different types of not showing.
    I don’t know what people are thinking of my art website with no paintings showing! I’m sure visitors are not impressed!
    Please help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    I’ve gone through all the support threads but none seem to answer this problem.

    Have you tried deactivating your plugins? It sounds like Jetpack issue.

    Thread Starter The Fagan

    (@the-fagan)

    Sorry I did another thread on this topic. I’ve been off the internet (new connection with ISP) and didn’t remember. Also it’s hard to find old/recent threads quickly and easily!

    As to no images on my pubic side of my website:
    I disconnected the Jetpack plugin as you advised and my images appeared. Great, but now I don’t have the other services they provide, eg: no stats on how many people come to your website, etc! So why have they done this with the new version?
    What other plugin does WP provide that gives us full coverage?
    Thanks for answering my requests while I was away. Appreciated your kind help.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    That’s alright, maybe re-enable Jetpack but instead try deactivating its ‘modules’. I think deactivating the ‘Photon’ module has worked for some people.

    Thread Starter The Fagan

    (@the-fagan)

    How do I deactivate the `Photon’ module? Where do I find it?
    But why is JetPack behaving this way, ie not showing images in the first place? Everything was fine before!

    I am having the same problem too, but it is with maps. They are not loading and map icons too, aren’t showing.

    mkm

    (@mkmuneer242)

    Our website is also same issue. Not showing images in live website. Please help.

    Images are uploaded successfully. Those are there in Media library.

    I have the same problem.

    Please somebody should help.

    Solved.

    I have renamed my .htaccess file, then it just fixed.

    mkm

    (@mkmuneer242)

    @aminudidat

    Hi how do you rename?

    can you please explain to what name you renamed.

    mkm

    (@mkmuneer242)

    Hi I dont have installed jetpack plugin in my wordpress.

    Jamison Davis

    (@thestephenpaulsongroup)

    I had a similar problem. I have a wordpress.org website through other hosting services. Also, I added SSL crt to website. Images worked in wordpress.org php dashboard once permission was changed. Images still didn’t work through wordpress.com dashboard. Instead of turning Jetpack off and on, I deactivated the image performance in Jetpack. I think I disconnected images from WordPress.com’s server since I don’t really have an acct with wordpress.com. Images on my website works fine, now. Hope this helps.

    Image not showing on live website. It is on the dashboard and the view the site. On the page it says readability not good for those pages. What can I do?

    mkm

    (@mkmuneer242)

    Somebody help pls. images not showing in the website , also not showing in the wordpress media library (media library shows empty boxes of images, also when I try to add new images to the wordpress media library its ending with an error ” unable to create directory wp-content/uploads/2018/08 ”

    I dont have installed jetpack plugin.

    Resolved – put images into media library again

    I have found the same issue when using JetPack.
    Solution that worked for me: Turn Lazy Loading for images off.
    Refresh. 😀

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Images not showing on website!’ is closed to new replies.