Images Not Showing on my new theme (17 posts)

  1. killion
    Posted 7 years ago #

    I have just uploaded a new theme but images are not showing on all posts. I am fairly new to word press or scripting.

    have a look here:


    Can someone have a look and let me know how to resolve this..?


  2. buddha trance
    Posted 7 years ago #


    you will have to look at the instructions for your theme, from the author.

    Looking at the source code, your theme is actually displaying images, it's just that it's the jpg "no image thumbnail". Which is the default image if there is no custom field.

    				<img src="http://boidus.co.uk/wp-content/themes/premiumnews/images/no-img-thumb.jpg" alt="" class="th" />

    Also, I noticed that there is a "featured" class for some images. I have seen a theme like this around, where you have to create a "featured" category and use it for those posts that you want featured.

    Try creating a new category called "featured" in your admin settings. Then add that category to a post, and see if it will display there.

  3. MarkRH
    Posted 7 years ago #

    Well, one of the posts http://boidus.co.uk/?p=4 is trying to display this image: http://revitbrother.com/wp-content/uploads/2008/07/sg1l7818-150x150.jpg

    That image doesn't exist there anymore when trying to view it individually. Sounds like a simple case of an image being removed on someone's website.

  4. buddha trance
    Posted 7 years ago #

    Yes, it looks like the image is not where it's stated in the path to it.

    Did you by any chance change the path to your uploads folder in admin settings, for instance did you check off ordering by date? If the post was created prior to the change, the path is the old one.

  5. killion
    Posted 7 years ago #

    Thanks very much MarkH and buddha trance for your reply-suggestions:

    1. I have tried replacing image:


    with an image from my flirk account but this is still not showing...so i guess it is not because of image location

    2. How do I direct this script:

    <img src="http://boidus.co.uk/wp-content/themes/premiumnews/images/no-img-thumb.jpg" alt="" class="th" />

    \to look for an URL and use that instead of a blank (no image picture..?)

    Thanks again for being helpful.


  6. buddha trance
    Posted 7 years ago #

    Upload an image into your wp-content/themes/premiumnews/images folder, and change the code to

    <img src="http://boidus.co.uk/wp-content/themes/premiumnews/images/NAME-OF-THE-NEW-IMAGE.jpg" alt="" class="th" />

    at least, it will display something else than the "no image" thumbnail.

  7. brew13
    Posted 7 years ago #

    Killion, I don't understand why you are seeking assistance here. I checked your theme and it's was written by a company that is well known for providing fast high quality support. In fact, I checked their website and there are theme installation instructions that answer all of your questions.

  8. killion
    Posted 7 years ago #

    thanks again buddha but this still does not resolve my problem. I have tried changing the cache code in my:/boidus.co.uk/wp-content/themes/premiumnews
    from '666' to '777' and '755' but still nothing. at the moment i getting this note if i right-click propoerties where the image is meant to be;

    file size: Unknown (not cached)

    have a look at the first 3 posts here and see what i mean..?


    must be something simply that i don;t know to activate. I have read and followed this guide from the markers site but still nothing:


  9. buddha trance
    Posted 7 years ago #


    yours is strictly a theme issue. Not a WordPress one.
    Looking at the instructions you mention, the points below are the ones you need to make sure you are following properly for the front page to display the images.

    Did you create the special "featured" category?

    "4. Adding Featured Posts (Homepage Only):

    Setting up the featured section

    1. First you need to create or identify a specific post category that you would like to use as your featured category. You can create a category by going to Manage > Categories in the WP admin panel.
    2. Now go to Premium News Options and select the appropriate category as the “Featured Category”. Then save those options.

    Adding the post (basics)

    1. Go to Write > Post.
    2. Type a title for the post and complete all of the post’s body content.
    3. Make sure to select the appropriate category (as you have specified on the theme options page - see above).
    4. Once you have completed the post’s body content, copy a section of that body content, which you will use as the shortened summary of the post on the homepage. Now paste that section of content into the “Excerpt” field further down the page."

    Woo themes has also a support forum, where they can guide you through the steps, and they will know how to help you, since they created the theme.

  10. coldequations
    Posted 7 years ago #

    Killion, did you ever resolve this issue? I'm having the same problems, and since I downloaded one of Woothemes' free themes I don't have access to the forums.

  11. girish949
    Posted 6 years ago #

    Hi buddha trance
    I am also facing the same problem..I also don't have access to the forums.
    Plz can you tell me whole step by step procedure..?


  12. steee
    Posted 6 years ago #

    any news on this? i got the free theme =[

  13. affectiveartistry
    Posted 6 years ago #

    It's both a theme issue and wordpress 2.7 issue. It has to do with the way the images are called in the custom fields. The change needs to be made within the php. I don't know enough about it to make it work in 2.7 but I'm still searching. If someone here knows php and can help it would make this free theme usable in the new version of wordpress.

    Here's an example of what I mean. The magazine theme, Branford Magazine, needed the same changes made to get the images to show:
    I have tried hacking the code for the premiumnews theme but have had no success yet.

    If anyone figures it out, please post the fix here.

  14. killion
    Posted 6 years ago #

    Hi all

    I tried a lot of things to resolve the image issues but could not solve the problem. In the end i downloaded another free theme to use. Its not perfect but will do for now. Please let me know if you ever solve this problem.

  15. Grumbledook
    Posted 6 years ago #

    the images need to up uploaded into the themes
    /wp-content/themes/premiumnews/images/ folder otherwise it will not work

    if you want to edit this then you need to edit the /includes/featured.php file

    if you upload the image to the theme image folder then you just need to put the full url into the box at the very bottom of the edit post page

    should work fine then

    you may need to use a FTP program to get the image there as the build in media uploader in wordpress will put them in the uploads folder instead

    the editing method will take more explantion so I suggest you just use that images folder instead

  16. Alexel75
    Posted 6 years ago #

    Sorry for my English.

    I have a problem with this item.

    Two sitis install.

    In one works perfectly (http://www.futbolregio.com) Hosting neubox.net

    In the latter simply does not work (http://www.soccerkids.com.mx) Hosting HostGator.com

    Is exactly the same installation and midificado item.

    What can be treated.

    And try to give file permissions.


  17. shizazzlemag
    Posted 6 years ago #

    How can I edit the script to look for the files in the uploads section.

    Please help


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.