Support » Plugin: Jetpack by » Images not showing in post

  • Resolved osotp


    I´ve been using Jetpack for 1 year and it has been working ok since now.
    All images published in my post have desappeared except for the 3 first images.
    I´ve updated to WP 3.5 but the problem remains.
    Only deactivating Jetpack plugin the images appear again.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic

    Could you post a link to your site, so we can have a look?

    Could you also check if the Jetpack Photon module was activated? If so, could you try to deactivate it and let me know if this helps?

    You can find out how to deactivate a module here:

    If none of this helps, could you try to deactivate all other plugins on your site, and se if one of them conflicts with Jetpack?

    I think I’m having the same issue. When I look at the browser error log, here’s what I see for all the images:

    Network Issue: Failed to load resource: the server responded with a status of 400 (Bad Request)

    If I turn Photon off, my images come back, turn it on, they’re all gone with this same error message.

    I’ve tried turning off all my other plug-ins, but it makes no difference. I did have a previous version of Photon working with WP3.4, but since updating to WP3.5 and the version of Jetpack before this one, I’ve had this problem.

    Site is , but I have to leave photon off, as the images are all gone when it’s on.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    We’ve just released a new update to the Jetpack release.

    Could you update, and let me know if this helps?

    I just updated to 2.1 about an hour ago–I guess this is the one you mean? I was hoping this issue would have gone away with the update, but it hasn’t.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    I am sorry to hear that 2.1 didn’t solve the issue.

    Could you post the image URLs of some of the broken Photon images, so we can investigate further?

    Okay, I dug into this, and the problem was all me–I had hotlink protection enabled on my server, and it was restricting from accessing the original files.

    Added to the permitted referrers, enabled direct requests, and everything seems to work as it should.

    Thanks for your help, anyway 🙂

    What’s weird, and was misleading in finding the problem, is that photon worked before, and I hadn’t touched the hotlink settings in years.

    Plugin Contributor Christopher Finke


    (Marking thread as resolved.)

    Premature resolved marker Christopher … the 2nd poster’s issue has been resolved, but not the Original Poster’s. The 2nd poster managed to nicely hijack the thread instead of starting his own.

    Seeing this a lot of late in the WP forums.

    Updated to Jetpack 2.1 and issue not resolved.

    Deactivating Photon resolves the problem, so… goodbye Photon.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    @gazouteast @osotp Could you post your sites’ URLs, so we can investigate further?

    It would also be useful if you could post a few of the Photon image URLs returning errors.

    Of course, if you don’t want to post your site URL here, you could always contact us privately here:

    I´ve re-activated Photon so you can see the issue:

    This post should show 21 images, but only 3 appear… And the same with the rest of the posts.

    Where can I find the Photon returning errors?

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    Although you’ve activated Photon, I still see the old version of the post, probably because it was cached by W3 Total Cache. Could you try to clear the page’s cache?

    I also noticed that you use another plugin to control your images and have them lazy-loading. Could you try to deactivate this plugin, clear W3 Total Cache again, and see if that helps?

    If it doesn’t, I am guessing you should see small red crosses, or a broken symbol instead of the images? If so, could you right click on the broken image, and copy its URL?

    Cleared W3 cache.
    Deactivated lazy-loading.
    Re-activated lazy-loading.
    Everything seems to work ok (I don´t know how)

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    Well, glad to hear you’re all set! 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Images not showing in post’ is closed to new replies.