WordPress.org

Forums

NextGEN Gallery
Images not showing in Nextgen Gallery (31 posts)

  1. slates27
    Member
    Posted 1 year ago #

    Just upgraded Nextgen gallery to version 2 and WP 3.6, when I upload a new photo to an existing gallery:

    1. The thumbnail is blank and can't be viewed
    2. There is just an x where the nnn x nnn pixel size should be
    3. The date is showing up as Jan 1, 1970

    Anyone else seeing this and know a workaround?

    http://wordpress.org/plugins/nextgen-gallery/

  2. apricotree
    Member
    Posted 1 year ago #

    I am experiencing the exact same issues. I am also noticing that when I upload an image it renames it... so image.gif is renamed image-gif

    Additionally in the page I have a gallery displayed where I am trying to upload the images I notice there is a longer link ie.

    The images displaying correctly links to this:
    mysite.com/blog/wp-content/gallery/page/image.gif

    but the images I've since tried to upload and fail show up as blank thumbnails when I rollover them it links to this:
    mysite.com/blog/index.php/wp-content/gallery/page/image.gif

    For some reason it is adding the "index.php" which is unnecessary. Where can I fix this?

  3. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, a few thoughts / questions.

    Can either of you tell us if

    a) you are on a windows-based server
    b) you are using a separate WordPress URL vs Site URL under General Options?

    -
    If you'd like us to take a closer look at this, please feel free to submit a bug report with login credentials (WordPress and FTP) via our bug report form. The email will go right to our tech support.

    http://www.nextgen-gallery.com/report-bug/

    Please say Erick asked you to send credentials and include a link to this forum thread so we know the issue.

    Thanks.

  4. slates27
    Member
    Posted 1 year ago #

    Hi,

    Can either of you tell us if

    a) you are on a windows-based server
    b) you are using a separate WordPress URL vs Site URL under General Options?

    a) No, Linux based servers
    b) No, just using the one URL.

    I have reverted to the previous working version of Nextgen Gallery as version 2.0 messed too many other things up.

    Hope info above helps,
    Sy

  5. dekpass
    Member
    Posted 1 year ago #

    I have the same problem. It seems to be random. I uploaded 22 images this morning and two show as ?. It happened last Thursday as well. I uploaded lots of images, but two or three refused to show.

    I also noticed that all the images in that gallery show a date of Jan. 1, 1970. The Jan. 1 date seems to be throughout as well. It's not every image, but it is there at least once in every gallery I checked.

  6. michaelo9
    Member
    Posted 1 year ago #

    Image gallery suddenly not showing on my website. Updated to latest WordPress version this morning. Don't know if there is conflict, didn't check image gallery before update. May just revert to older version of NextGen

    http://www.michaeloart.com/store/politics/

  7. cloud4xL
    Member
    Posted 1 year ago #

    Same issue as apricotree.

    Simple work-around for those who don't want to downgrade back one of the earlier versions:

    1) Create a directory in your "wp-content" folder that you will use to upload your images to.

    2) Upload the images you want to that folder using either FTP, your webhost's file management system, or through the WordPress Media Uploader. (NOTE: Depending on how you have your WP installation setup, if you use the WP Media Uploader, your images will either end up)

    2) From the WordPress backend/admin menu, go to the "Add Gallery/Images" sub-menu in the (NextGen) "Gallery" menu.

    3) Under the "Upload Images" panel, you'll see the "Import Folder" panel. Click it to open it up.

    4) Navigate to the new folder you just created to upload your images.

    5) Select that folder, and click the blue "Import/YOUR_FOLDER'S_NAME" button.

    6) Next, click on the "Manage Galleries" sub-menu.

    7) You should see the name of the folder you used to upload your images as the name of a newly created gallery. Click the name of this gallery.

    8) Click the checkbox next to "ID" to select all of the images you've just uploaded from that folder.

    9) In the "Bulk Actions" drop-down, select "Move to...", and click the "Apply" button.

    10) Select the gallery you want to move the images to, and click the "Ok" button.

    You should now have all of the new images you uploaded in the gallery you need. One thing to note is that if you use the WordPress Media Uploader to upload your images, you will end up with about 3 copies of the same image at different resolutions, so make sure that if you use WordPress to upload your images, you only select the ones you want to move to your gallery in Step 8 (instead of checking the "ID" checkbox to select all of the images).

    Hope this helps anyone else encountering this problem, and if anyone figures out how to fix the problem so we don't have to use this method to upload images, PLEASE POST IT! Thanks!

  8. gsuveg
    Member
    Posted 1 year ago #

    i have same problem, on Linux server. i'm uploading daily pics, no better workaround ?

  9. ghostfreak
    Member
    Posted 1 year ago #

    Having the same problem (linux server) but when I click on Overview > Images it states 'You do not have sufficient permissions to access this page.' - but I am the admin with all the relevant permissions.

  10. diamondmi
    Member
    Posted 1 year ago #

    I did everything as outlined 1 through 10 and I cannot view any of the images. They all show as small icons looking like broken images. I can't tell what kind of server is in General settings.

    Mark

  11. apricotree
    Member
    Posted 1 year ago #

    We are on a linux server. We are just using the site url. I'll create a support a bug report. It sounds like there are more than just a few people experiencing this issue... :) cry! I don't think I want to go back though, the update eliminated 3 other issues I was having. We are using the skirmish theme btw.

    Thanks - Cindy

  12. spotoremor
    Member
    Posted 1 year ago #

    Hi,

    Im experiencing this issue as well. I'm using WP 3.6 and NextGen 2.0, and my site is on Linux. After creating a gallery and uploaded images, or just added images to an existing gallery. The images are not displayed.

    My work around is to manually chmod 755 the gallery folder.

    Hope to have this issue addressed, this is a great plugin.

    Thanks
    Spot

  13. apricotree
    Member
    Posted 1 year ago #

    So I tried to create a bug report Erick as asked... but it is asking me to create a wrike.com account? is this legit? I filled out the form and clicked send and got an email as follows...

    You’ve just sent an email with the subject “[NextGEN Gallery/Unverified] Images not showing in Nextgen Gallery” to wrike@wrike.com. If you are a Wrike user and wanted to create a task from that email, we have to let you know that it has not happened. The task was not created in Wrike because the address (myemail@msn.com) from where you sent the email is not known to the system yet. If you would like to add this email to your Wrike account as a secondary address, please follow the link:
    https://www.wrike.com/gotoprofilesettings.htm?secondary_email=schilaty%40msn.com.

    Then resend the “[NextGEN Gallery/Unverified] Images not showing in Nextgen Gallery” email to Wrike to create a task in the system.

    If you are not a Wrike user yet, but you want to create tasks from emails, share them online with email recipients and receive timely task reminders, you can create your personal Wrike account now. Follow the link and get your FREE, 15-day trial: https://www.wrike.com/gotoregistration.htm.

    Wrike is the most practical project management software with thousands of users and industry awards, such as Red Herring’s Top 100 Global award and eWeek’s Excellence award.

    This is an automatically generated, one-time email and will not be followed up. Please note that if you send more tasks from this email address before registering in Wrike, the system will ignore them. We look forward to seeing your email associated with an existing or new Wrike account.

  14. zsasz24
    Member
    Posted 1 year ago #

    I was able to workaround this issue by creating a new gallery.

    Next, I copied the images across from the old gallery to the new gallery.

    Then, I updated the gallery ID number in the page/post used.

    I had only a few galleries so didn't take too long to do.

  15. apricotree
    Member
    Posted 1 year ago #

    Okay so I just did the latest update this morning. Now I am attempting to upload images and it is giving me 0 percent uploaded error... where before it would upload and say it was 100% but nothing would show up and the meta data would be wrong as above. I am comfortable uploading the images via .ftp as suggested above, but I'm helping a friend set up her blog for her illustrations and she has no experience with .ftp so I wish the plugin would just work :( I'm going to browse the support threads and see if I can find a solution. - Cindy

  16. apricotree
    Member
    Posted 1 year ago #

  17. Jacob311
    Member
    Posted 1 year ago #

    I also am showing the 0 percent uploaded error when uploading an image. Also from the Overview panel, if I click where it says "0 Images" (because I can't upload any) it gives me the error that I don't have sufficient permissions to view that page, but if I start in the Add Gallery/ Images panel I can at least get to the page to upload an image. Those are what I've found so far. Attached are screenshots. Looking forward to the update.

    Thanks
    http://dsnamerica.com/eisn/wp-content/uploads/2013/08/Screen-shot-2013-08-23-at-12.01.02-PM.png
    http://dsnamerica.com/eisn/wp-content/uploads/2013/08/Screen-shot-2013-08-23-at-12.01.28-PM.png

  18. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hey All,

    Sorry to hear about the issues you've had with uploads. :( We should have most upload issues resolved now. Please check the following:

    - You're running v2.0.11 of NextGEN Gallery
    - Permalinks under Settings >> Permalinks are set to 'Post Name' > save changes > clear browser cache
    - If you're getting permission error, please confirm with your host that you:
    -- have 755 permissions set to /wp-content directory + all subdirectories
    -- PHP Safe Mode is turned OFF

    Let me know if that helps.
    -Becky

  19. Paolodura
    Member
    Posted 1 year ago #

    Same problem on version 2.033.
    I change all permission on 755, Permalink set to post name. I'm on linux.
    No image in the gallery, just a ?

  20. Andi@DSM
    Member
    Posted 1 year ago #

    I just updated to the latest version of WordPress and the latest version of NextGen Gallery. When I try to create a NextGen gallery, everything seems to be working as it should be, but in the end there are no images in my gallery. My process was as follows: I go into Add gallery/images, Add Files (select 5 images) Open, (now I can see the files on my AddGallery page) Start Upload, (now I see the files being uploaded), receive message "upload complete 5 images were uploaded successfully". Then I go into manage gallery and I can see my new gallery, but it is empty--0 images. Never had this problem before.

  21. Andi@DSM
    Member
    Posted 1 year ago #

    Can anyone help with above mentioned issue?

  22. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Paolodura and @Andi@DSM - This was a very old topic but obviously one still important to you ... and to us.

    In this case, would it be possible for you to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/) so we can get a better look at what might be going on with your site and help you get it sorted out.

    We will likely need log in credentials and FTP credentials as well, please include those with your Bug Report, too.

    Thanks!

    - Cais.

  23. iQuid
    Member
    Posted 1 year ago #

    I have the same when i'm creating a new gallery the folder of the niew gallery is in the chmod 744 and the picture in the chmod 644.
    Before i have made a chmod 755 on all folder in wp-content and wp-admin.

  24. Andi@DSM
    Member
    Posted 1 year ago #

    @Cais - Thanks. I submitted the bug report, but did not include login info. I have tried resolving this issue in a number of different ways. You mentioned that this is a very old topic. How was this issue finally resolved for others?

  25. metalrecusants
    Member
    Posted 1 year ago #

    Hello,

    I have a similar problem, I think. I tried using all the solutions mentioned above but nothing seems to work. I am running the latest version of NextGen.

    All pictures that are in my galleries do not show in both in the admin section of the plugin and do not show on the website. Here's how it looks:
    Admin section: http://metalrecusants.com/wp-content/uploads/2013/11/gallery-problem.png
    Real-site: http://wp.me/p1JkdH-3FS

    I noticed that the problem here is that the links are incorrectly generated by the plugin. If I right-click (or hover over) the thumbnail to open it in a new window, I get this link: http://metalrecusants.com/wp-contentgalleryparadise-lost-25th-anniversary-30th-october-2013-wulfrun-hall-wolverhamptonkatatonia2.jpg

    However, it should be like this: http://metalrecusants.com/wp-content/gallery/paradise-lost-25th-anniversary-30th-october-2013-wulfrun-hall-wolverhampton/katatonia2.jpg and when I type that into my browser, the picture shows up.

    I do not how to fix this problem. Anyone could help?
    Thank you for your replies and help in advance. I very much appreciate it.

  26. Ann Stokes
    Member
    Posted 1 year ago #

    Same bugs

  27. Drew McIntyre
    Member
    Posted 1 year ago #

    Same problem, thumbnails will not show in manage gallery page. tried going back to earlier versions no joy.

  28. metalrecusants
    Member
    Posted 1 year ago #

    Problem got solved by itself with the latest update!

  29. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Andi@DSM - Sorry for the delay in responding, are you still seeing this issue with the latest release?

    Thanks!

    - Cais.

  30. pmagony
    Member
    Posted 1 year ago #

    Running latest versions of both WP and NextGen plug-in and the only output on my front-end is the short code.

    This only happens when I add a short code to output most recent blog articles on the same page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.