NS Cloner - Site Copier
[resolved] images not showing after cloning (9 posts)

  1. Diana
    Posted 2 years ago #

    Multisite, made my site in english and cloned 3 times to make different languages. Sites cloned nicely!! No images though (the whole media file uploads did not clone, read through support and found this issue several times but can´t figure out where to copy my uploads to manually. I have tried copying the whole 2013 folder from wp-content/uploads/2013 to wp-content/uploads/sites/6/2013 through ftp but that does nothing. Where should the folder 2013 go to? To wp-content/blogs.dir/6 ?
    Or did I do something wrong and should I start over?
    The nextgen galleries have all cloned without a problem, it´s just the uploaded media folder.
    http://test.sophieblom.com/ (original site)
    http://test.sophieblom.com/deutsch/ (clone)
    Thanks for any help, I am not good at this and have no clue what to do.


  2. Diana
    Posted 2 years ago #

    This part of the log file may help?
    2013-10-14 10:01:40 - Original basedir returned by wp_upload_dir() = /home/sophiebl/public_html/test/wp-content/uploads
    2013-10-14 10:01:40 - Non-standard result from wp_upload_dir() detected.
    2013-10-14 10:01:40 - Normalized content_dir = /home/sophiebl/public_html/test/wp-content
    2013-10-14 10:01:40 - Found actual uploads folder at /home/sophiebl/public_html/test/wp-content/blogs.dir/1
    2013-10-14 10:01:44 - Copied: 1693 folders and files!
    2013-10-14 10:01:44 - From: /home/sophiebl/public_html/test/wp-content/blogs.dir/1
    2013-10-14 10:01:44 - To: /home/sophiebl/public_html/test/wp-content/blogs.dir/8
    2013-10-14 10:01:44 - Entire cloning process took: 12.6293599606 seconds.

  3. Never Settle
    Plugin Author

    Posted 2 years ago #

    Hi! One thing you can do to identify the correct location is to create a new site using the standard Add Site in the Network Admin area, then go to that new site and upload an image, then explore the directories through FTP and see where it landed. That might give you enough clues to figure out how to mimic it and where to copy the other files to for the previous ID location. Depending on your version of WordPress and upgrade history the right location could vary.

    However, even then, it's possible that that if the files are in the right spot the file paths in the clone are off if something is unusual about your hosting or environment.

    If you'd like to send us the cloner log files from /wp-content/plugins/ns-cloner-site-copier/logs we'd be happy to take a look.


  4. Never Settle
    Plugin Author

    Posted 2 years ago #

    Ah! Posted at nearly the same time. Yes, that does help.

    So, it looks like if you copy your 2013 folder to here:
    it should work. Final location should look like:

    Hope that does the trick!

  5. Diana
    Posted 2 years ago #

    will try now and let you know, thanks!

  6. Diana
    Posted 2 years ago #

    no change...media files uploaded : wp-content/blogs.dir/6/files/2013 but still nothing shows.. also tried putting it directly into blog.dir/6 but that does not work either. any other ideas? Thanks

  7. Never Settle
    Plugin Author

    Posted 2 years ago #


    Ok, can you look at the URL behind the missing images in the clone site by inspecting the HTML source getting rendered to the page and see where they are pointing? What location is is looking for on the page / content? That might tell us where you need to put them. That would be the next thing to check.

  8. Diana
    Posted 2 years ago #

    I have fixed it but will leave it up to you to try and figure out WHY this works... I uploaded to both wp-content/blogs.dir/6/2013/
    AND wp-content/uploads/sites/6/2013 and now it works. Does that make any sense?

  9. Never Settle
    Plugin Author

    Posted 2 years ago #

    Hmmm... maybe it's just the second try that is working. Looking at the logs it looked like you had an older original version of WP but maybe the Cloner couldn't auto-detect it correctly. I'm guessing the last location was the correct one. Glad you figured it out!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NS Cloner - Site Copier
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic