WordPress.org

Forums

TablePress
[resolved] Images not showing (8 posts)

  1. Janus Andersen
    Member
    Posted 1 year ago #

    I'm using TablePress with the TwentyTwelve theme. Great plugin and extremely easy to work with!

    The only problem I've encountered is that when I insert an image from the media library, the image doesn't show. Only an empty square with a dropshadow shows.

    http://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    Please post a link to the page with the table, so that I can take a direct look. Thanks!
    Most likely, there's something wrong with the URLs or the HTML code.

    Regards,
    Tobias

  3. Janus Andersen
    Member
    Posted 1 year ago #

    Wow! That was a quick response! Thank you.

    The link is here:
    http://biosapartner.com/marketing-material/

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for the link!

    I'm not exactly sure, but it seems that the Lazy Load plugin that you are using is not properly initialized for these images, probably due to the internal caching in TablePress. Due to that, only that plugin's placeholder image (which is transparent) is shown.
    Please try again after changing the table's Shortcode in the page to

    [table id=2 cache_table_output=false /]

    Regards,
    Tobias

  5. Janus Andersen
    Member
    Posted 1 year ago #

    Hi,

    It seems I have to disable the Lazy Load plugin to make the images visible. So your assumption about the plugin was right. But the extended shortcode doesn't do the work. I guess I have to uninstall Lazy Load altogether and hunt for an alternative (I'm not even sure how much it impacts the speed of the site - it was recommended to me).

    Janus

  6. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Janus,

    ok, if the extended Shortcode does not help here, then that Lazy Load plugin must have a different mechanism of initializing its code. Unfortunately, I don't know what that is or how TablePress could be disturbing that.
    Deactivating that plugin is indeed the best option then. Additionally, you can go back to the shorter version of the Shortcode then.

    Regards,
    Tobias

  7. Janus Andersen
    Member
    Posted 1 year ago #

    Thank you, Tobias. You've been enormously helpful.

  8. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    no problem, you are very welcome! :-)

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TablePress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags