Support » Networking WordPress » Images not showing

Viewing 15 replies - 1 through 15 (of 31 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    this is the default behaviour. It’s supposed to upload the image to one location on the server and rewrite the URL to the second one.

    this is done via the .htaccess file. Go double check it. if it’s fine (just like what it should be under Tools -> Network) then go tell your webhost you made htaccess changes and they are not being read.

    @andrea_r you are a star. Amazing. Thanks for the support. I knew I had to say something to my host but did not know what. Txs

    Hi Just for info. I did what Andre_r suggested. It took a while for my host. Eventually my host got back and said:

    RewriteBase /snapshots/
    Was causing this error. I have commented out this directive and the image is accessible.

    All working.

    Thanks again for helping me out.

    shazzam

    (@shazzam)

    I commented out:

    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ – [F,NC]
    on blue host, .htaccess in addon domain folder

    and BINGO!!! 🙂

    Thanks Heaps 🙂

    @ Johanhorak: i’m really happy for you… I got the same problem..can you give me specific details on how you commented out? not savvy really… thanks

    @shazzam: please help me:got the same problem but i dont know where to start solving it..
    thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    bobjom – Don’t double post.

    What’s the full content of your .htaccess file?

    RewriteEngine on

    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com$ [NC]
    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ – [F,NC]

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    ———————–

    OK this is on bluehost, and it has a main domain that is your public_html folder.

    each subdomain is a folder in that folder.
    You can install and copy installs of wordpress from your cpanel, i copied one i think, i am going back some time now.
    so…. othersub/(in the htaccess file above) is the one that is not the one for this install.

    This is also an MU (multi user) install… so, you may have multiple blogs in subfolders of your wp folder.

    Mine is installed in the root of the subdomain sub/ (in the htaccess file above)

    So you may only need to change the line in your .htacces file as follows:

    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ – [F,NC]

    or

    if you want a MU install as well, copy other wp stuff.

    You may PM me if you want more help, and i can give you my email address 🙂

    Hope this helps for blue host 🙂

    Shazzam

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I would remove (or comment out) this whole section

    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.othersub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.sub.maindomain.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.maindomain.com$ [NC]
    # RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

    Yep, but save it as .htacces_old first, to make sure you can go back when ever you like 🙂
    Good Luck
    Shazzam

    thanks for your overwhelming response guys:
    my .htaccess is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    thanks ipstenu and shazzam: By the way my setting is sub category: maindomain.com/site1/ does this will matter?i will try this today…hope i will be getting luck this time…

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Your htaccess looks fine. What’s your URL?

    my main URL:http://www.loudounstyle.com and my sub site: http://www.loudounstyle.com/events/ i’m using or chose trhe sub category when installing the wordpress MU.

    even if i single post only..still it wont show up…is there like we need to activate something?

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Images not showing’ is closed to new replies.