WordPress.org

Forums

Images not mapping (4 posts)

  1. vikashautar
    Member
    Posted 3 years ago #

    I am having a weird issue with images. On the multisites the images will upload, but will show the image not found image.

    I thought it could have been the domain mapping plug but I turned off all plugins (even on the FTP) and the issue still arise. I've looked up the uploaded image file on the FTP and it's there.

    What can I do to fix this?

    My main site is fine by the way.

    this is my .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    
    # END WordPress
  2. When you set up multisite, it said to replace the old .htaccess rules:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    What version of WP were you using when you activated Multisite?

  3. vikashautar
    Member
    Posted 3 years ago #

    I was probably using 3.3 or 3.4.

    I actually put the code in the .htaccess that WordPress network setup gave me. Are you saying I should replace this code with the code that you just gave me?

    I actually deactivated all plugins and the issue still exists.

    Thanks for your help!

    Vikash

  4. Yes, replace. :)

    If you were using 3.4 you very much need to switch to the old htaccess rules.

Topic Closed

This topic has been closed to new replies.

About this Topic