Support » Fixing WordPress » Images not loading when using https

  • kerrya4446

    (@kerrya4446)


    Perplexed.

    When accessing my site with http, all images load normally.

    When accessing the site with https, 99% of images will not load.

    1) SSL cert is installed
    2) Used advanced search and replace to change all references in the database to http to https
    3) Using File Explorer on the server to confirm all images are in uploads directory for WP
    4) Confirmed there is no mixed content on the site using whynopadlock.com

    As we have an active ad campaign I need to have the images loading so I have turned off the “Force https” feature in cPanel and set the default URL’s in WP Settings/General to http.

    This is the only way I can get the images to load.

    Try it: ( warning – this is a boudoir photography site)
    http://sizzle.photography/ (images will load)
    https://sizzle.photography/ (images will not load)

    I have tried this on Chrome, Firefox and Edge with the same results.

    I’m out of ideas. Any help appreciated.

    Kerry

    [Warning: NSFW]

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images not loading when using https’ is closed to new replies.