WordPress.org

Support

Support » Plugins and Hacks » Images not loading on homepage with plugin

Images not loading on homepage with plugin

  • Hi. I have version 0.6.8 of your BJ Lazy Load plugin installed on WordPress 3.5.2 and am having a problem on the homepage of this site: http://staging.collegespun.com/

    None of the post images show up, so I checked the source and see that the images lazy-data-src and src are both pointing to the plugin’s placeholder image:

    <img width="285" height="213" src="http://staging.collegespun.com/wp-content/plugins/bj-lazy-load/img/placeholder.gif" data-lazy-type="image" data-lazy-src="http://staging.collegespun.com/wp-content/plugins/bj-lazy-load/img/placeholder.gif" class="lazy lazy attachment-category-featured-thumb wp-post-image data-lazy-ready" alt="Flickr/missycaulk" style="display: block;">

    The plugin is loading in the wp_footer() and I have confirmed that it is loading correctly in the source (line 794):

    <script type='text/javascript' src='http://staging.collegespun.com/wp-content/plugins/bj-lazy-load/js/combined.min.js?ver=0.6.8'>

    It also seems to work on posts and pages correctly.

    Can you help?

    Thanks!

    http://wordpress.org/extend/plugins/bj-lazy-load/

Viewing 3 replies - 1 through 3 (of 3 total)
  • We’re having the same issue. On individual posts and pages all works correctly, but on the index page with custom content the supposedly lazy loaded images are shown as blank. Firefox Inspector reveals that the src and data-src both point to the blank 1×1 placeholder image.

    The custom content links are added this way:

    $replace = wp_get_attachment_image($imageID, 'full');
    if ( class_exists( 'BJLL' ) ) {
      $replace = BJLL::filter( $replace );
    }

    Loading the script at wp_footer() or wp_head() makes no difference. With both combined.min.js is correctly loaded and can be inspected in Firefox Inspector’s Debugger.

    No repsonse, so we went with another plugin which works very well: Advanced lazy load. It doesn’t allow lazy loading of widgets, but does a great job with images and causes no errors.

    Thanks, we look forward to giving that one a shot. Here’s a link for convenience: http://wordpress.org/plugins/advanced-lazy-load/

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images not loading on homepage with plugin’ is closed to new replies.