Support » Plugin: SG Optimizer » Images not loading – Javascript Combo disabled

  • Resolved golfczech2

    (@golfczech2)


    I have had to turn off Lazy Loading images – my images are not showing up on my mobile site since the 5.7.11 update. However, now the page speed on mobile is at 33 with the following message:
    “We have detected that a script is generating uniquely named files which results in our combined assets taking up huge amount of disk space. Please, exclude any scripts that generate unique JS code per page or per visit in order to avoid this from happening again.”
    Any idea if there will be a fix in the next update?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hello there @golfczech2,

    The error message regarding the JS Combination means that there is a script that is creating a unique ID, causing the Combinator to make a new file for every new visit. Most of the time this is caused by plugins like sliders, dynamic ads, and scripts generating unique content.

    In order to fix that, you can enable the JS Combination. After that, you can exclude the scripts from the combination using the Exclude from JavaScript Combination.

    For the Deffer Render-blocking JS, we recommend excluding the jquery.min.js and jquery-migrate from loading asynchronously.

    As far as the issue you were having with the lazy load, I was not able to replicate the issue on my end. If the issue still exists, please provide steps to recreate, a specific page that you are having the issues, since when I checked everything was fine. Also, your site gave a page speed index of 60 on mobile and 94 on desktop.

    If you still have any issues, feel free to reach back to us.

    Kind regards,
    Stoyan

    Thread Starter golfczech2

    (@golfczech2)

    Absolutely nothing has changed. I am still getting the Javascript error message and there are no images on the mobile as long as I have lazy load enabled. When I turn the lazy load images off the pictures reappear. My page speed is currently a 40 on mobile using the Google Developers PageSpeed Index. Is there an alternative to SG Optimzer because it is not working on my site. I turned the Render-blocking JS off and my page speed went up to a 66 and I no longer get the error message.

    • This reply was modified 2 months, 3 weeks ago by golfczech2.
    • This reply was modified 2 months, 3 weeks ago by golfczech2.
    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey @golfczech2,

    Since the issue is related to the Defer Render-blocking JS, if you are using this option, make sure ‘jquery-core’ and ‘jquery-migrate’ are excluded from the list, if you are using them, since the issue may be caused by that.

    Also, make sure that all of your plugins scripts can run deferred, meaning that they can be executed after the site has loaded. Also, make sure you are not using multiple optimization plugins since that can also cause unexpected behavior.

    If you have more questions feel free to reach back at us.

    Kind regards,
    Stoyan

    Thread Starter golfczech2

    (@golfczech2)

    My biggest issue is the lazy loading. It will not load images on my mobile, no matter what I turn on or turn off. When will there be a new update? Otherwise I will just go to a different optimization plug in as lazy load seems to be very important to the site speed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.