Support » Plugin: Smash Balloon Social Photo Feed » Images not Loading and not loading HTTPS

  • jayxcamps

    (@jayxcamps)


    HI there,

    For some reason, my feed is not displaying correctly on my website. It was working fine a few days ago, but not sure what happened. I also noticed that my website is not loading with the Padlock next to the domain name.

    I tested it out and see that when i deactive the plugin for smashballoons, the padlock reppears. So i took a deeper dive into the console and found this

    Mixed Content: The page at ‘<URL>’ was loaded over HTTPS, but requested an insecure image ‘<URL>’. This content should also be served over HTTPS.
    (index):1 Mixed Content: The page at ‘https://newmooncreative.co/&#8217; was loaded over HTTPS, but requested an insecure image ‘https://newmooncreative.co%09/wp-content/uploads/sb-instagram-feed-images/2230025782846094119_24288113low.jpg&#8217;. This content should also be served over HTTPS.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Craig at Smash Balloon

    (@craig-at-smash-balloon)

    Hey jayxcamps,

    It looks like the path to your uploads folder, which our plugin uses to retrieve stored local, resized images is incorrect. The plugin is getting this path:

    https:/newmooncreative.co\t\/wp-content/uploads/

    Notice that there is a \t\ added. Any idea where this comes from?

    We can help you out with this either way. We have a plugin that we normally offer for help with CDNs you can install that should also correct this. Contact us on our website to get the download link:

    https://smashballoon.com/instagram-feed/support/

    Thanks!

    – Craig

    Hi, I’m having a similar issue – I’m on multisite with mapped domains – your plugin seems to be displaying the images from the subdomain (we have the site mapped to a domain and images need to pull from the mapped domain to avoid mixed content warnings). Any help you can provide would be greatly appreciated!

    Plugin Author Craig at Smash Balloon

    (@craig-at-smash-balloon)

    Hey Brad,

    I’m wondering if this snippet will help:

    `function sb_change_for_cdn() {
    ?>
    <script>
    if (typeof window.sb_instagram_js_options !== ‘undefined’) {
    window.sb_instagram_js_options.resized_url = ‘https://smashballoon.cdn.net/wp-content/uploads/sb-instagram-feed-images/&#8217;;
    }
    </script>
    <?php
    }
    add_action( ‘wp_footer’, ‘sb_change_for_cdn’, 99 );

    Change the “https://smashballoon.cdn.net&#8221; part to the URL to the domain you would like to use for the resized images.

    Does that work?

    – Craig

    Plugin Author Craig at Smash Balloon

    (@craig-at-smash-balloon)

    Hey again,

    Sorry I noticed that this wasn’t very clear and the formatting came across a bit odd.

    You would add this to your theme’s functions.php file:

    function sb_change_for_cdn() {
    ?>
    <script>
        if (typeof window.sb_instagram_js_options !== 'undefined') {
            window.sb_instagram_js_options.resized_url = 'https://smashballoon.cdn.net/wp-content/uploads/sb-instagram-feed-images/';
        }
    </script>
    <?php
    }
    add_action( 'wp_footer', 'sb_change_for_cdn', 99 );

    Let me know if this works for you!

    Thanks @craig-at-smash-balloon, I was able to throw that into the snippets plugin and it fixed it on that site. But I’m on a multisite with mapped domains – is there any way to provide some code that I can put into a must-use plugin that will dynamically fix this issue for any mapped domain on my network that has the plugin activated? I’m considering purchasing your All Access Bundle, but I need to make sure this issue can be permanently corrected without having to add code to each site before I seal the deal. I’d prefer to not have to fix this every time I go to use the plugin on a client site.

    Thank you!!

    Plugin Author Craig at Smash Balloon

    (@craig-at-smash-balloon)

    Sure I think we can figure something out. Is there code that will retrieve the mapped domain or some kind of pattern I could put together? I can help you dynamically set the resize url then.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Images not Loading and not loading HTTPS’ is closed to new replies.