Support » Plugin: Master Slider - Responsive Touch Slider » Images Not Loading

  • Resolved wordpressnerdsh

    (@wordpressnerdsh)


    Hey there,

    I’m having a really bad problem where images are sometimes not loading in the slider.

    It’s really random. Sometimes they load, but sometimes they do not (the image is blank, and all I see is the background)

    Can you take a look?

    http://snapyourfilter.com/

    There are slider pages under “Buy a Snapchat Filter” – “Wedding Filters” “Funraisers”, etc.

    The images seem to load the FIRST time, but on multiple visits of all the pages then the images start to randomly not load.

    Thanks very much

Viewing 15 replies - 1 through 15 (of 20 total)
  • Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    As well, I did pay for the pro version a while back, but my support is expired.

    Plugin Contributor averta support

    (@averta_support)

    Hi,

    Thank you for choosing Master Slider.

    Please put the below code on slider callbacks -> on slider init

     jQuery(window).load(function(){
      jQuery(window).trigger('resize');
    });

    Please let me know the result.

    Best,
    Averta

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    Can you please clarify which file you are talking about?

    Thanks.

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    I have recorded a video so you can see what I am seeing. It loaded 3 times, and then the 4th time, just a black screen.

    Is there a way I can send you this video?

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    As well, many times after that it is still black, and then it randomly loads after a while. I also tried enabling:


    Load assets on all pages? By default, Master Slider will load corresponding JavaScript files on demand. but if you need to load assets on all pages, check this option. ( For example, if you plan to load Master Slider via Ajax, you need to check this option )

    but this didn’t seem to help

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    The problem happens way more, when I have these plugins enabled:

    Easy Modal

    Popup Maker

    however, even with these plugins disabled the problem still occurs, just less often.

    To me, it seems like the more data the site has to load, the more of a chance there is of the image not loading.

    I thought it was a direct plugin conflict at first (with the popup plugins), however because the problem still occurs without the plugins enabled, it seems to be an indirect conflict of some sort….

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    Here is a video I recorded so you can see what I am seeing:

    Plugin Contributor averta support

    (@averta_support)

    Hi,

    You can find slider callbacks as I show on the below screenshot:

    http://support.averta.net/en/wp-content/uploads/Master-Sliders-Callbacks.png

    Then choose on slider init and after adding that, put the below code on the opened text box:

     jQuery(window).load(function(){
      jQuery(window).trigger('resize');
    });

    Also, on Slider Settings tab -> Navigation -> Slide preloading, choose slides in sequence.

    If you have any plugins for lazy loading and image optimizing, please disable those plugins and try again.

    Best,
    Averta

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    Hey there,

    Thanks very much.

    I tried the above, and now the sliders are completely not loading.

    This is with plugins activated, and with all plugins deactivated – except for Master Slider and Visual Composer (both are up to date)

    I don’t have any lazy loading plugins.

    All I could find related to Javascript was these settings in the Theme (Jupiter Theme):

    -Minify Theme Javascript File
    If you enable this option pre-minified theme Java Script files will be renderred in front-end. Minified JS is 30%-40% smaller in file size which will improve page speed.

    -Minify Theme Styles Files
    If you enable this option pre-minified theme CSS files will be renderred in front-end. Minified CSS is 30%-40% smaller in file size which will improve page speed.

    -Query String From Static Flies (Not Recommended)
    disabling this option will remove “ver” query string from JS and CSS files. For More info Please Read Here.

    -Portfolio Post Type
    If you will not use Portfolio post type feature simply disable this option.

    -News Post Type
    If you will not use News post type feature simply disable this option.

    -FAQ Post Type
    If you will not use faq post type feature simply disable this option.

    -Pricing Tables Post Type
    If you will not use Pricing Tables post type feature simply disable this option.

    -Clients Post Type
    If you will not use Clients post type feature simply disable this option.

    -Employees Post Type
    If you will not use Employees post type feature simply disable this option.

    -Testimonial Post Type
    If you will not use Testimonial post type feature simply disable this option.

    -FlexSlider Post Type
    If you will not use FlexSlider post type feature simply disable this option.

    -Edge Slideshow Post Type
    If you will not use Edge Slideshow post type feature simply disable this option.

    -iCarousel Post Type
    If you will not use iCarousel post type feature simply disable this option.

    -Banner Builder Post Type
    If you will not use Banner Builder post type feature simply disable this option.

    -Tab Slider Post Type
    If you will not use Tab Slider post type feature simply disable this option.

    -Animated Columns Post Type
    If you will not use Animated Columns post type feature simply disable this option.

    I disabled all of these next, and still no load.

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    I see the slider loading a blank.gif, rather than the proper image.

    A video of what I see now.

    Thanks, I’m hoping to get this figured out soon – having to completely rebuild with a new slider would be less than convenient.

    Thanks again,

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    Oh, and I also did this:

    “Also, on Slider Settings tab -> Navigation -> Slide preloading, choose slides in sequence.

    If you have any plugins for lazy loading and image optimizing, please disable those plugins and try again.”

    All of these attempts were done individually, not all at once

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    *Individually, adding one on to the other

    1. added jquery snippet as suggested

    2. changed navigation settings

    3. tried disabling potential settings conflicts, in theme settings

    Plugin Contributor averta support

    (@averta_support)

    Hi again!

    Please like this example -> http://support.averta.net/en/wp-content/uploads/callback-4.png

    add the below code to slider callbacks -> on slide change start:

    jQuery(window).load(function(){
     jQuery(window).trigger( 'resize' );
    });
    }

    Let me know if the problem persists.

    Best,
    Averta

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)


    function(event){
    var api = event.target;

    jQuery(window).load(function(){
    jQuery(window).trigger(‘resize’);
    });
    }

    I put this code in the slider, for both “On Slider Init”, and “On slide change Start”.

    Nothing.

    I also tried putting the code in both.

    Nothing.

    What’s next?

    thanks

    Thread Starter wordpressnerdsh

    (@wordpressnerdsh)

    If I could get support at a time other than 12 in the morning, that would be appreciated as we could actually work through this problem more quickly.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Images Not Loading’ is closed to new replies.