Forums » Plugin: Amazon Associates Link Builder » Images not load over https

  • Resolved rsaez

    (@rsaez)


    My site is https and the images from amazon load them from http, so the browser blocks them.

    The plugin should load the images from https or allow to change it.

    Thx!

Viewing 6 replies - 1 through 6 (of 6 total)
  • More or less same problem: images load, but images appear very elongated; unable to select products or ascribe short link…also uses https, not http.

    Any solutions?

    Yes i’have problems with mixed content because Https not support the charge of Http images from aws server.

    I have a lot of failed loading at console log.

    Is posible redirect (overwrite) on htaccess to forcr the https images loading?

    Thanks!!

    Same problem !!

    Same problem, our site runs over https and mixed content are blocked by browsers.

    I edited wp-content/plugins/amazon-associates-link-builder/lib/php and replaced:

          $aalb_node->LargeImageURL =  $item->LargeImage->URL;
          $aalb_node->MediumImageURL = $item->MediumImage->URL;
          $aalb_node->SmallImageURL = $item->SmallImage->URL;

    by:

          $aalb_node->LargeImageURL  = preg_replace( '#^http://ecx.#','https://images-eu.ssl-', $item->LargeImage->URL  );
          $aalb_node->MediumImageURL = preg_replace( '#^http://ecx.#','https://images-eu.ssl-', $item->MediumImage->URL );
          $aalb_node->SmallImageURL  = preg_replace( '#^http://ecx.#','https://images-eu.ssl-', $item->SmallImage->URL  );

    With this, all is working fine.

    • This reply was modified 7 years, 4 months ago by ABCdatos. Reason: Solving attemps failed
    • This reply was modified 7 years, 4 months ago by ABCdatos. Reason: Solution applied
    Thread Starter rsaez

    (@rsaez)

    Also works perfect for me.
    We already have a solution until the creators of the plugin implement it.

    Thank you!

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Hi rsaez, leonbejar83, mirinda1177, expatdoc, ABCdatos,

    The issue with HTTPS images is now fixed as the Product Advertising API is now returning HTTPs images by default.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Images not load over https’ is closed to new replies.