Support » Fixing WordPress » Images not indexed by google since w3-cache/cdn

  • Last week I installed w3-cache and moved all the images on http://www.coffeeandvanilla.com to a cdn( maxcdn.coffeeandvanilla.com ).

    The problem I’m having is that although the sitemap—generated by yoast wordpress seo plugin—points images to the correct location, google only indexes[sic] images from the category and page site maps but 0 images from the posts sitemap( see screenshot https://dl.dropbox.com/u/4635252/sitemap.png )

    This website has been doing quite well with google image-search before the change, visits from google image search have dropped from ~200/day to 11 yesterday

    Here is an example entry from the generated posts.xml sitemap http://pastebin.com/vcMRf9VW

    Can anyone suggest where the problem lies? My wife(it’s her website) is killing me over this, I’m at the end of my tether.

Viewing 3 replies - 1 through 3 (of 3 total)
  • This will help:
    seo api docs
    Look at the bottom of the page for:
    Switch XML Sitemap image URLs to CDN

    This is in my functions.php

    function wpseo_cdn_filter( $uri ) {
    	return str_replace( 'http://www.coffeeandvanilla.com', 'http://maxcdn.coffeeandvanilla.com', $uri );
    }
    add_filter( 'wpseo_xml_sitemap_img_src', 'wpseo_cdn_filter' );

    Unless the code goes somewhere else.

    What I don’t get is that images on category-sitemap.xml and page-sitemap.xml are all indexed but posts-sitemap1 & 2 aren’t.

    @dfunkydog Did you find a solution for this problem? I’m in the exact same position. And I’ve also added the code to my functions.php file.

    Saw your post on the Webmasters StackExchange as well.

    Cheers,

    P.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images not indexed by google since w3-cache/cdn’ is closed to new replies.