WordPress.org

Support

Support » Plugins and Hacks » Shopp Image Tools » [Resolved] Images not getting removed from the database

[Resolved] Images not getting removed from the database

  • Hello,

    Thank you for this plugin but I’m having a little issue. As the subject states, the images aren’t being removed from the database. The images are being appropriately copied to the file system and no errors are thrown but the images are still in the database. I had ‘Enable smart cleanup’ checked and I also tried running the Orphan Cleanup Tool but it just keeps running and running and running. The text box states

    “1. Starting orphan cleanup: 0 valid asset(s) currently in the database, 160 asset(s) to scan for possible orphans” but nothing ever happens.

    I’m running the site on my local server with Xampp.

    Any ideas?

    Thank you,
    Eric

    http://wordpress.org/extend/plugins/shopp-image-tools/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi Eric,

    Just to clarify – you don’t see a second statement in the console reading [Process ended] – it just stops completely?

    Hello Barry,

    Basically, it doesn’t really ‘stop’ as that would imply that a change occurs after it has started. No change occurs, it just simply continues to show that it has started and remains that way.

    And in response to your question on the Shopp Plugin site: “Did you select the Enable Smart Cleanup checkbox and/or have you tried running the Orphan Cleanup tool?” Yes, I tried both ways, first with the Smart Cleanup box checked then the Orphan Cleanup tool, those didn’t work so I restored the database and tried again without the Smart Cleanup checked, just using the Orphan Cleanup tool, same result for both.

    Thank you,
    Eric

    OK, well there’s clearly an error somewhere.

    Are you familiar with the Javascript console and network tools in your browser of choice? If so, can you see any errors there (or can you determine what the last ajax response is)? If that isn’t something you’re comfortable with are you able to access the error logs (you could check in with your web host if you are unsure about where to find these) and see if there are any obvious indicators there?

    Barry,
    Having a similar issue. No Javascript errors in the console, but it is throwing the following PHP error:
    PHP Fatal error: Call to undefined function getimagesizefromstring() in /home/fourcorn/public_html/wp-content/plugins/shopp-image-tools/inc/orphanfinder.php on line 142

    It looks like the function getimagesizefromstring()is only included in PHP version 5.4.0+ – I’m looking for a replacement function, though I will look into upgrading PHP soon as well.

    Could not find a suitable replacement function, so proceeded to upgrade to PHP version 5.4.15 which has solved the issue. Thanks!

    Good catch, I’ll probably disable the orphan finder for installations sub-PHP 5.4 unless I can find a convenient alternative 🙂

    Barry Hughes

    @websitebakery

    Wow, 6 months has flown by. For the benefit of anyone stumbling across this in search of an update for the same problem: Shopp 1.3 arrives soon and an updated version of Shopp Image Tools is ready to ship at the same time – it will remedy this by disabling Orphan Cleanup on servers with older versions of PHP.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Images not getting removed from the database’ is closed to new replies.
Skip to toolbar