Support » Fixing WordPress » Images not following formatting

  • Hey guys. Hope everyone is well and staying safe.

    I’m not new to WordPress and my site loads fine, but the pictures seem to be messing up the flow of everything.

    For instance, in my blog posts, the pictures are all askew – the formatting is crazy, even on old posts. I never had this problem before, so I did a lot of Googleing and tried “Regenerate Thumbnails” but that didn’t seem to do anything.

    Any suggestions for me?

    • This topic was modified 2 years, 5 months ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, Skaorsk8.

    After the WordPress updated to 5.0 (new Block Editor), many themes started to need a “spacer” between paragraphs in order to maintain the flow of the post.

    For example from your blog post, the photo is off the flow after the quote “your time where friends can see your thanks.” This can be fixed by inserting “spacer” after your phone photo or before No.3 update.

    This is a link to how to use a spacer using WordPress Block Editor 🙂

    • This reply was modified 2 years, 5 months ago by Jun.
    • This reply was modified 2 years, 5 months ago by Jun.
    Thread Starter skaorsk8


    Hi Yjunjung,

    Thanks for the reply! So your reply was very helpful, except my WordPress didn’t look like the example you sent, even though I was on version 5.4. I couldn’t find “Spacer Block” anywhere

    I sat there and thought about it … and realized that when I updated to 5.0, I wasn’t in the mood to figure out new things, so I installed a plugin called “Classic Editor”. Disabling that gave me the options I needed – and actually, once I deleted the images (and re-added them), turns out I didn’t need the Spacer Block at all!

    Page looks great – thank you for your help!!

    However, I’m having the same spacing problem on my Category lists page – the posts with thumbnails are all weird. Any thoughts on how to fix that part?


    You are welcome! Ahh That is how it happened! Yeah some people or a lot of people still prefer to use Classic Editor.

    Have you tried re-adding the images like the one you did in the blog post? Or tried using the block editor method by putting spaces between each category?

    If above methods do not solve the issue, link below is a screenshot where I changed the custom css properties of each “article” tag in the developer mode. Have you played around with Custom CSS section located in your theme customizer? You can put this tag and should fix the problem.

    #et-main-area #left-area > article {


    This kind of stuff requires a basic understanding in HTML and CSS. To summarize briefly, the default display of article tag — which indicates each of your category list — is “block” so I changed to “inline-block” in order to align them in stacks. Please let me know if you have any questions.

    • This reply was modified 2 years, 5 months ago by Jun.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images not following formatting’ is closed to new replies.