Support » Fixing WordPress » Images not displaying on site, nor in media library, but DO exist

  • Weird problem, not experienced by other wordpress installs at same server.

    No images are displaying on the site, nor in the media library. But they DO exist in the library (confirmed in FTP file manager, and also when I “edit image” in the media library it displays – so it DOES exist).

    Audio files are not affected – appear in media library AND on site without problem. Same upload routine (via WP media library upload button).

    Running WP 4.4.2 and Divi theme (as are other sites I’m using without this problem).

    There are NO plugins activated at all.

    Looked all round help & support forums, but can’t find this problem replicated or resolved. Can anyone help please?

    (site is http://laphooka.co.uk )

    Many thanks

Viewing 12 replies - 16 through 27 (of 27 total)
  • I am having the same issue. After update in WordPress, all images appear as broken thumbnail. I have updated my theme, reinstalled plugins and even changed theme to no avail. Initially was even unable to see dashboard in WP, but that has since been resolved by adding a ssl certificate from my host. Seems as though this is caused by some security conflicts. Currently all images display in media library as broken thumbnails, and I am unable to see them in editor. Being a newbie to WP, I have no idea how to proceed. Thoughts, suggestions?

    I got this advice from a tech-savvy friend, and this was the cause of my problem – it was completely resolved afterwards. The problem was something that had happened in cpanel – ie with the hosting platform control. Hope it helps. …….

    You have this code in the public_html/YOURSITE.com/.htaccess file:

    RewriteCond %{HTTP_REFERER} !^http://ANOTHERSITE.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://ANOTHERSITE.com$ [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ – [F,NC]

    This is added by a feature in cPanel called Hotlink Protection – designed to stop other people linking to / embedding your images in their website. Your own domain is not on that list, so it is blocking the images on your own site too! You also have “Allow direct requests” unticked, which is why you can’t access the images directly.

    If you add your domain to the list it should fix it. I would also tick “Allow direct requests” because some firewalls disable the referrer header and make all requests appear to be direct requests. Alternatively you could just turn off Hotlink Protection.

    I have the same problem a well. Also since updating to WP4.7.

    I can upload images (through the uploader in the library), it works I see them apear in the uploads folder (in different sizes). However, I only see the default.png thumbnail.

    What did I try: disabled all plugins, changed to twenty sixteen, checked file permissions, reinstalled (manually) WP4.7. It didn’t work.

    The htacces looks fine, since uploading works, I asume the image path is ok (I don’t see a setting for this in settings/media).

    So I’m stuck. Hope someone can help me!

    Hi,

    I am having the same issue as gbet44.

    I have only some posts where my images are not displaying. And, I’m only seeing the problem for images where I’ve created the image using “Insert from URL”. After inserting the images, I edit the image and change “Link To” to ‘Custom URL’ and enter where the image should link to if clicked.

    On this specific post (URL below), one image is working (search for “BUY BALI”) and the following four images do NOT display (they instead only show the link I’ve entered using the image “Alternative Text” as the anchor text for the link). The first broken one can be found by searching for “FANCY FLORES”. Here is the URL:

    http://www.thecoffeebeanmenu.com/best-indonesian-coffee/

    The additional strangeness is that on my Windows PC, the images are broken if I use Firefox, IE, or Edge. But, the images all work if I use Chrome or Opera. The browsers are up to date in terms of their software versions. On my MAC is works on Chrome and Opera correctly. But, is broken on Safari and Firefox.

    I see the same type of behavior when I go into the post in WordPress and edit the post. Same behavior where images work on some browsers and not on others while editing this post.

    I’ve turned off all plugins and get the same behavior.

    Per the previous suggestion, I checked Hotlink Protection from my cpanel, and it was Disabled.

    BTW, I found another thread that talked about having this issue because their post was HTTPS, but their images were HTTP. This was causing their issue. I don’t use HTTPS. So, that’s not my issue.

    Thanks in advance for any help that can be provided.

    Regards,
    Jagger

    • This reply was modified 3 years, 10 months ago by jaggerwarellc.
    • This reply was modified 3 years, 10 months ago by jaggerwarellc.
    • This reply was modified 3 years, 10 months ago by jaggerwarellc.
    • This reply was modified 3 years, 10 months ago by jaggerwarellc.

    After some debugging, I found that the images I get from Amazon look like this:

    Image that works on my site:

    https://images-na.ssl-images-amazon.com/images/I/511qqDztZNL._AC_US240_QL65_.jpg

    Image that does NOT work on my site:

    https://images-na.ssl-images-amazon.com/images/I/61TptP31ZeL._AC_US240_FMwebp_QL65_.jpg

    The main difference between the two that I could detect was the inclusion of “FMwebp” in the middle of the link. So, I removed that part of the link and now that image works on my site.

    I have no idea why the “bad” URL works on some browsers and not on others. I mostly use Chrome to edit my web site, so when I was inserting these “bad” image URLs, they were working fine on Chrome.

    Anyway, for me, this seems to be an Amazon on browser issue. Now the fun part of finding all of my images that have this problem and changing the URL.

    I hope this helps someone. But, I suspect this is likely limited to a “me” problem.

    Regards,
    Jagger

    same problem here.
    i use ssl for website. and child theme.
    before update to new version, everything was fine.
    after update, the pictures are not showing anymore!

    Had the described issue. In my case the solution was very simple. I have set up my site for https only, and under general WP settings, I still had http in the set website URL. After chnaging it to https, all images are properly displayed

    This is probably not the case for most, but figured I’d share — I was building a site and contacted the theme designer for certain Custom CSS code, customizing the site. Turns out one of the codes actually was the cause of the images no longer showing up on the site. I deleted everything from the Custom CSS section to figure it out.

    I have serious problem here with my images. They appear in my wordpress by do not show in the post on the Website after publishing.
    The website id https://www.digitalofers.com

    A problem THAT happened just 2 days ago. The images are NOT found in the folder where the images links:
    https://digitalofers.com/blog/amazon-wordpress-theme-offers/wp-content/uploads/2017/01/

    The images are in other folder https://digitalofers.com/wp-content/uploads/2017/01/…..

    So far, the difference is that the images are uploaded in the WP installtion folder for Media files.
    While the image URL leads to an other folder.

    Everything looks great in wordpress, but after posting, you realize, images dont appear on the website.

    I need help please.

    same issue as trouble2017… watching post

    no help please

    still have not been able to resolve the images issues

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Images not displaying on site, nor in media library, but DO exist’ is closed to new replies.