Support » Fixing WordPress » Images not displaying in WordPress 3.5.1

  • Resolved NickyJiggy

    (@nickyjiggy)


    Hello!

    I updated our blog to WordPress 3.5.1 and now our images are not showing up when we upload them. I have checked the master list and researched the forum, followed every step to try and resolve it but I still can’t find a solution. The problem is NOT with my hosting or javascript, it is NOT with my plugins or settings, it is a WordPress issue. Some of the images don’t seem to have transferred at all and are not displaying in the media library, even though everything looks right (they are attached and have the right file url). When I insert the image to my post, it shows up as a broken image icon. When I click the link to try view the image, I get an error “403 Forbidden Access to this resource on this server is denied” powered by LiteSpeed Web Server – ?

    I have been using WordPress for years and never had this issue, I don’t seem to be the only one with this problem… Can anyone help me out with a solution here? Thank you!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator t-p

    (@t-p)

    Do the problems occur in the default theme with no plugins?

    to check, try:

    -deactivating ALL plugins (yes, all) temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can’t get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

    – To rule out any theme-specific issue, try switching to the unedited default Twenty Twelve theme for a moment using the WP dashboard. If you don’t have access to your admin area, you can switch to the default theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using via FTP or SFTP or whatever file management application your host provides.

    A link to the site would be relevant.

    WPyogi-

    http://www.satphonestore.com/blog, there you go.

    Thank you Tara for you helpful and kind reply, I have already tried disabling plugins and pretty much everything as I stated previously. I’m not sure exactly what is causing this

    We are using the twenty-twelve theme latest version, I have already tried to switch to Twenty Eleven theme and another theme I have just to make sure. Still does not solve the problem.

    WPyogi- What do you suggest at this point? Thank you again

    Since we do not know how your site is supposed to look, can you point us to a page containing one of these “missing images”?

    There does not seem to be valid image tags in the HTML –

    <a target="_self" href="http://www.inmarsattx.com/IsatPhone_Pro_Firmware/IsatPhone_Pro_firmware_5_3_0_release_note.pdf">http://www.inmarsattx.com/IsatPhone_Pro_Firmware/IsatPhone_Pro_firmware_5_3_0_release_note.pdf</a>

    Hi Esmi,

    Sure thing, here is a link to the post, should have a picture but doesn’t display just a link that takes me to the error message –

    http://www.satphonestore.com/blog/get-ready-for-hurricane-season-by-testing-your-satellite-phone/

    Also in my latest gallery post –

    http://www.satphonestore.com/blog/photos/ it has errors (and it is not the plugin, checked many times)

    Looks like a permissions issue on your site. Check that anti-hotlinking isn’t enabled in your hosting account. If it is, try disabling it.

    Hi Esmi,

    Thank you for the suggestion, but just checked with my hosting company and we do not have hot linking protection enabled. Any other ideas of what the problem could be?

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Do you have anything in your .htaccess file that’s doing it?

    This image is tossing a 403 Not Authorized error.

    http://www.satphonestore.com/blog/wp-content/uploads/2013/06/test_your_phone_week1-300×111.jpg

    Which looks a lot like hotlink image protection as Esmi said. Or the file and or directory permission may not be set correctly (also as Esmi said). Make sure that their set as in this Codex article.

    http://codex.wordpress.org/Changing_File_Permissions

    Hi Esmi and Jan,

    They said hotlinking wasn’t active but I asked about the directory permissions and they did a check on it. Turns out that was the issue! Thank you both very much for your help, you guys were great and I really appreciate it!

    Glad we could help 🙂

    deleted.

    @jsdosanjh: It is impolite to interrupt another poster’s thread with a question of your own. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please continue with your previous topic.

    Ah sorry about that mate. Thought mine may have been ignored for not having a look for previous threads with a similar problem.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Images not displaying in WordPress 3.5.1’ is closed to new replies.