Images not displaying in posts problems with 2.8.4 (6 posts)

  1. restlessknight
    Posted 6 years ago #

    Hello All,

    I am having an issue with uploading images in posts. The image will upload (can see the file) but will display as a broken link in the post.

    This also seems intermittent, as I can sometimes upload without an issue.

    I am running the most current version of these plugins:
    Add to Any
    All in One SEO
    Easy Adsense
    Get Recent
    Google Analyticator
    Google XML Sitemap
    SEO Smartlinks
    Share This
    Sidebar Login
    Theme Test Drive
    WordPress Automatic Upgrade

    My site is http://www.armiesofchaos.com

    If you look, you will see that some posts have images and some have broken links, but I have verified that the pis are uploaded, and have even tried deleting and uploading them again.

    The only other pertinent fact I can think of to share with you is that I did move this site from a sup folder into the main folder of my site.

    I am still learning as I go, and any help would be greatly appreciated!


  2. alism
    Posted 6 years ago #

    Ok, the first post has a broken image. The URL is:
    ...so that hasn't been uploaded, which is why its showing a 404.

    Can you check the URL you believe the image to be located at?

  3. restlessknight
    Posted 6 years ago #

    I did, what I found was that, even after uploading it (I got a complete, but it did not display the image)

    I dug into the directory structure and found that the \10 directory was not created. I created it myself, and manually uploaded the files, but they are still broken links...

  4. restlessknight
    Posted 6 years ago #

    I have also noticed that when I view the gallery, it shows broken links as well.

    Could there be a pointer issue somewhere in the code since I moved my site?

  5. alism
    Posted 6 years ago #

    I'd guess it's something to do with your Settings > Miscellaneous page.

    The first box should say:

    Make the second box blank, or if that doesn't work:

    Tick the organise my uploads into months/years if it's not selected already.

    Try uploading another image and see how you get on with that. If not, there's a moving wordpress guide that you might want to run through, to see if you've missed a step out somewhere.

  6. restlessknight
    Posted 5 years ago #

    That solved it...
    The first box still had the old address.

    Thanks so much for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic